Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Gnome-shell GNOME/openbox, not Unity, on a dual display.

My top and bottom panels are always on my laptop screen. I really want them on the external monitor when that is plugged in. I've read a ton of tips about using gconftool-2 and gconf-editor to switch the "monitor" key from 0 to 1 for each panel, but doing that has no effect.

I can use alt super right to access the panel properties and move the panel to the top / left / right / bottom of my laptop screen, but I can't for the life of me move it over to my external monitor.

I recently rearranged my desk and don't know what all I customized six months ago when I was setting up my desktop environment. So one question is ... could I have done something to give control over my panels to something other than gconf-editor? How would I figure that out?

Thanks!

share|improve this question
    
Can you confirm if you're using GNOME Shell or GNOME Panel? –  8128 Jun 25 '12 at 18:09
    
I'm not actually running Gnome-shell - I use classic mode, so this may not work at all (hence the comment), but I can move the top panel by doing "alt-meta + right-click", choosing "properties", then unchecking "expand". I can then drag it with my mouse to where I want it, and reverse the procedure to again check "expand". –  Marty Fried Jun 25 '12 at 18:11
    
@fluteflute Good point. I logged out and back in to check (is there an easier way to know???) that I'm running GNOME/Openbox. Question updated to reflect that. –  Amanda Jun 25 '12 at 18:24
    
@MartyFried BINGO! That works. I even edited my question to stave off the "alt-meta-right" tips, and then I read your comment again. I'd still love to understand what is going on here, but if you want to post your comment as an answer I'll definitely accept it. –  Amanda Jun 25 '12 at 18:26
1  
@MartyFried I think it's precisely "why can't I drag an expanded panel" but I doubt the answer is entirely technical. –  Amanda Jun 25 '12 at 21:05

3 Answers 3

up vote 3 down vote accepted

I'm not actually running Gnome-shell - I use classic mode, but I can move the top panel by doing "alt-super + right-click", choosing "properties", then unchecking "expand". I can then drag it with my mouse to where I want it, and reverse the procedure to again check "expand".

share|improve this answer

On my Gnome 3.8.4 (Ubuntu 13.10) the right way to do that operation was going in monitor settings, and drag&drop the panel from the monitor to the other one (pointing the cursor on the little monitor pictured in the image box).

Here's a screenshot (sorry, the user interface is not in english):

Screenshot of the operation

share|improve this answer

To do anything with panel the key combination is win+alt+click. Do that and you will get properties option.You can easily configure it after that.

share|improve this answer
    
I can move the panel to the top/bottom/right/left of my laptop screen with super-alt-click, but I can't move it from my laptop to my external monitor. –  Amanda Jun 25 '12 at 18:15
1  
well with unity i get it on both of the screens,with gnome panel i think you should check it with your graphics card settings or the monitor settings in system settings. –  Vinit Jun 25 '12 at 18:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.