Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Ubuntu 12.04 system with x86-64 bit system architecture. Every time I try to install any windows OS using virtual box it shows error "FATAL ERROR: boot medium halted or not found". What do I do next? What is causing this problem? Tried several online links for installing windows OS on Ubuntu using Virtual Box and also for installing virtual box. The virtual box is installed correctly as per my thinking.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Is the hard drive image still attacked to the virtual machine? If not, attach it as a SATA controller.

enter image description here

share|improve this answer
    
what is the difference between different virtual disks that it asks to create? –  Srijan Jun 25 '12 at 19:24
1  
Got it! have to setup virtual hard disk as .vmdk and not as .vdi. Thanks man. you set the screws rolling. –  Srijan Jun 25 '12 at 20:40

This is not related to Ubuntu. This is an error within Virtual Box.

The meaning of the error message is that your virtual machine can't find any bootable media.

Make sure you specify in you virtual machine that it should search your physical dvd drive for the install dvd, or point it to the iso file containing your Windows7 install and it should work.

share|improve this answer
    
Yes I do select the .iso file directly for the boot.. still it is showing the same error... –  Srijan Jun 25 '12 at 19:22
    
Sounds like the ISO is broken then. You can verify burning it to a real dvd and attempting to boot. of.Or the easiest way wold be to to just make another iso. –  tomodachi Jun 25 '12 at 19:39
    
as mentioned above the problem was in selecting the type of hard disk to be created by virtual box, was initially selecting .vdi whereas I needed to setup in ".vmdk". Anyways thanks for your time. –  Srijan Jun 25 '12 at 20:38

Got the answer, as mentioned above. So please check which virtual hard disk you create before you actually create one. Problem was to setup in .vmdk and not in .vdi. There lies the answer to this problem. Thanks to those who gave thoughts to this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.