Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just built a new computer for myself, and having Ubuntu 12.04 on it, I decided it was time for some games, so I installed wine1.5, and loaded steam, sound works fine...

Until I actually load a game, in this case, Garry's Mod, at which point, it doesn't have sound. I've tried killing pulseaudio, this doesn't work, I've also tried uninstalling pulseaudio, this does more damage than it fixes, and didn't solve the problem, so I re-installed pulseaudio, opened up winecfg, and set all devices to pulseaudio, but this still didn't fix the problem.

What am I doing wrong, or what is Wine doing wrong, and how can I fix it?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I am no expert on wine, but I read this on Facebook earlier, let me know if it helps :

Marvin Mallari posted to Ubuntu 15 hours ago - For people having sound problems with Wine (like sound is garbled, static, non existant) in Ubuntu 12.04 (w/ Unity and Pulse/ALSA) i found a solution. Go to Synaptic Package Manager, install "ia32-libs-multiarch", it will ask to modify or install other packages, install all packages and restart (not log out then log in) Wine should now play audio perfectly and stable. note: i did this on a 32bit comp, for 64bit, there is probably a different package or maybe the package will work because it says "multiarch" i will try on my 64bit machine later. PS i don't have an account on any Wine or Ubuntu fourms so if someone can please share this somewhere that needs it that would be much appreciated!

Marvin Mallari - Ia32 probably isn't the solution but when I read the addition packages synaptic modifies and installs, a couple of them are for pulse so it is probably those packages that fixed it but in any case ia32 installed whatever it needed to work. It also seems like pulse cpu usage has dropped. Thanks for the info!

share|improve this answer
    
Thanks! I'm trying it now –  John Jun 25 '12 at 13:00
1  
It does work on my system, which is a 64-bit system, with the packages u mentioned. –  John Jun 25 '12 at 13:18
    
Great news, please accept & up-vote our answer to help others find this solution, and I will post a comment linking to this page for the author of the solution. :o) –  Fernhill Linux Project Jun 25 '12 at 13:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.