Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

First of all, I am abit intimidated by some of the patronising laguage that techies use on this site, so be kind.

When I try to Install Updates on my machine I get a message box headlined

Software index is broken followed by the subtext

it is impossible to install or remove any software. Please use the package manager "Synaptic" or run "sudo apt-get install f" in a terminal to fix this issue at first.

I have tried that and it doesn't help. The diagnostics suggest that the problem is with adobe-flashplugin. However, no matter what I do allows me to get rid of it. I looked on this site where it was suggested that I run a more specific sudo apt-get remove for adobe-flashplugin. This runs but does not remove the package.

I am now baffled, I cannot update my system because of it. Can anyone help?

share|improve this question
I see that you are "intimidated", can you provide a link so we know what it is you think is unwanted here so I can bring it up on Meta? – hexafraction Jun 25 '12 at 12:13
Try installing Flash from here, it will try to remove the conflicting flash plugins disabling you to update .I may sound stupid but i am just asking you to try. – atenz Jun 25 '12 at 12:18

There is a procedure in the Ubuntu documentation that will clear your "status" of dpkg, which is a low-level installer used by apt and apt-get. It may take a while, and while it is deleting things if you look at the commands, it is only deleting semi-temporary files that will soon be recreated if not unnecessary. It will not touch your personal files(home folder) or remove any programs. If the last command fails, try

LANG=C;sudo apt-get update && sudo apt-get dist-upgrade

in place of it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.