Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I shutdown or reboot my Ubuntu 12.04 it doesn't ever finish shutting down.

I end up stuck on a black/blank screen and have to hold the power button to shut it down.

Does anyone know where I can begin debugging this issue?

Thanks in advance

share|improve this question
    
Have tried modifying Grub? –  Mitch Jun 25 '12 at 10:25
    
No haven't modified GRUB. Worked fine before upgrading to 12.04 –  darryn.ten Jun 25 '12 at 10:28
    
contents of /etc/default/grub please? –  Mitch Jun 25 '12 at 10:35
    
/etc/default/grub doesn't exist for me (?) –  darryn.ten Jun 25 '12 at 10:42

5 Answers 5

You can find the logs at /var/log/syslog

Check the logs to get a better understanding of what is happening.

Also, try typing init 0 in the terminal.

share|improve this answer
    
Last 2 lines in syslog don't show anything suspicious: - kernel: Kernel logging (proc) stopped. - rsyslogd: [origin software="rsyslogd" swVersion="5.8.6" x-pid="1066" x-info="rsyslog.com"] exiting on signal 15. –  darryn.ten Jun 25 '12 at 10:29

By default, the latest ubuntu install (12.04.2, and few others behind) hides messages and shows a nice animated image (splash) in a fancy resolution.

To make sure to view the console and possibly see what's hanging behind that dark screen:

/etc/default/grub (edit & save):

# find line below and put a # in front of it
# GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
# and put this one:
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

Now update grub boot entries with these new defaults:

you@yourmachine:~$ sudo update-grub

And at your next start/shutdown process, you should see message lines with [ OK ] or [ ERROR ] or something wrong following it's title:

* Starting network shares                   [ OK ]
* Starting mysql server                     [ OK ]
* ...later when shutting down...
* Stopping mysql server                     [ OK ]
* Not Stopping something like it should     [    ]

nomodeset: You usually can toggle between the splash screen and the console messages with Esc key, but some video cards or lack of drivers can't handle the mode/capacities the boot process is using. nomodeset ensures it's using basic common capacities and makes sure you see messages (provided you don't press ALT-F1 to F7 during boot/shutdown to view other terminals than the one used for services startup/shutdown).

Edit: You can also try without nomodeset if you run into troubles starting X. GRUB_CMDLINE_LINUX_DEFAULT=""

share|improve this answer
    
Note that by doing this, you can also break your X settings and can result in your graphics driver not being loaded at boot. I would not recommend following bksunday's advice. –  Will. Sep 30 '13 at 21:07
    
I find it hard to view all the logs and find out what isn't working during shutdown. Would have loved to see your advice on the issue! Edited my answer now. Better? ;) –  bksunday Oct 1 '13 at 12:54
    
Thanks for the prompt response. I am having the same problem as well and haven't found a fix it - adding nomodeset does not display the console messages at shutdown for me unfortunately. Once I find a solution, I'll post it. :) –  Will. Oct 2 '13 at 15:15

I am somewhat new to Ubuntu 12.04 but I had used other versions of Ubuntu in the past. I have my account plus the guess account for my kids on this computer and if any of the account is logged in when the command to shutdown is given the computer will not even attempt to shutdown. The only way to shut it down if one of the account still logged is by logging out all accounts first and then providing the command from the login screen. I will shut down fine from terminal using the "shutdown -h now" command. Unfortunately I have still much to learn in order to attempt to correct this issue on my own.

share|improve this answer

I can't comment, so I'll post this as an answer:

I had the same issue on my 12.04 recently; in my case, it was due to one program (in my case pcscd) that wasn't stopped properly at shutdown and caused a 'cpu-lockup'. So, to turn of the splash screen (the ubuntu with the five dots):

  • hit 'escape' when you shutdown your computer.

  • you can disable splash in GRUB, but since you don't have that...

What messages are displayed on the screen? (look for something like "some process PID locks ..." (I forgot what the exact terms are...). If necessary, you can take a picture and post it here.

If you can confirm a process not being stopped normally, we can proceed by stopping it at shutdown via runlevel commands

share|improve this answer

I solved this problem by logging out first, then shutting down from the login screen. Shutting down without logging out first was resulting in a black screen, but with the power on the computer still on. I have Ubuntu set up with only one user so I'm not sure what's causing this problem. I haven't had a look to see if there are any processes running that are preventing shutdown as I'm very new to Linux and I don't actually know how to do that. A bit of searching will probably reveal the solution but if anyone can enlighten me here that would be great.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.