Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 10.04 installed on a Dell C600 and the highest available resolution is 800x600. From my previous I remember 1024x768 would work after setting the colour depth to 16bit, but there is no xorg.conf in /etc/X11 anymore. So, how can the colour depth be changed on lucid lynx?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

You can create a new xorg.conf by switching into a virtual virtual console (Ctrl + Alt + (F1-F6)) and running sudo service gdm stop.

Then run Xorg -configure (yes, it should be Xorg, not xorg). If you had an old xorg.conf file in /etc/X11/ you'd first back that up by doing sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup.

Then move your newly created xorg.conf to /etc/X11/ by running sudo mv xorg.conf.new /etc/X11/xorg.conf and restart gdm by running sudo service gdm start.

Then you can change the color depth in there by finding the appropriate section and changing/adding whatever's in there to DefaultDepth 16

share|improve this answer
    
Thanks, that changes the depth. Unfortunately, there seem to be more steps necessary, I still cannot change the resolution to 1024x768. –  Tobias Kienzler Aug 7 '10 at 12:13
3  
@IngoGerth: gnome's philosophy I guess... "Let's assume the dumbest possible user and insult even them by hiding important options" –  Tobias Kienzler Feb 25 '11 at 11:36

Try doing this step, but before you get to the sudo service xdm start part, change the screen section (within the xorg.conf file) to something like:

Section "Screen"
Identifier    "Default Screen"
Monitor        "Configured Monitor"
Device        "Configured Video Device"
DefaultDepth    16
Modes        "1024x768"
EndSection
share|improve this answer
    
replace xdm with gdm and it's fine –  Tobias Kienzler Aug 7 '10 at 12:08

The following is verified on Ubuntu 13.04:

Try doing this step: http://ubuntuforums.org/showthread.php?p=9362728#post9362728 , but before you get to the sudo service gdm start part, change (or add if there were none) the screen section (within the xorg.conf file) to something like:

Section "Screen"
Identifier    "Default Screen"
Monitor        "Configured Monitor"
Device        "Configured Video Device"
DefaultDepth    24
EndSection

In my case, depth used to be 32; I changed it to 24 to free some display memory so that I can plug a huge LCD display to it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.