Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install software by using apt-get and ubuntu software center UI, when I try the ubuntu software center it gets stuck saying installing and installs nothing and when I try the apt-get it gets stuck at the point "0% [Waiting for headers]"

I tried modifying sources.list file. I installed ubuntu this morning. Do you have any suggestions for me ?

Thanks in advance for your time.

edit : After a while, I get the error 502 bad gateway

share|improve this question
    
Did you check your Internet connectivity? –  Mitch Jun 25 '12 at 8:20
    
What should I check specifically ? I'm asking this question via the machine I installed ubuntu. Doesn't me being able to browse through stack exchange indicate that there is no problem in my internet connection ? –  Pumpkin Jun 25 '12 at 8:23

1 Answer 1

up vote 0 down vote accepted

In case you're still able to access internet, try opening up the Software Center. Select Edit and Software Sources. From there make sure that the "Download from" is set to "Main Server". If not, select it and type $ sudo apt-get update to the terminal. Outcome still the same?

share|improve this answer
    
Yes it is, waiting for headers %0 –  Pumpkin Jun 25 '12 at 8:24
    
Try this solution: askubuntu.com/questions/94831/… –  Kallestofeles Jun 25 '12 at 8:25
    
Forgot to write it, the servers in Turkey was faulty that day, that was my problem –  Pumpkin Oct 6 '12 at 16:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.