Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 in my notebook and I use C++. I want to use C++11, so I want to upgrade my gcc to gcc-4.7. I ran these commands:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test  
sudo apt-get update  
sudo apt-get install gcc-4.7  
sudo apt-get install g++-4.7  

But when I ran sudo apt-get install gcc-4.7, it can find gcc-4.7-base but not gcc-4.7. And when I ran sudo apt-get install g++-4.7, it could not find anything.

Today, I wanted to install bumblebee so I started to run these commands:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia
sudo reboot

But when I ran sudo apt-get install bumblebee bumblebee-nvidia, it told me the packages couldn't be found.

I used the Ubuntu 12.04 methods described here and here.

What can I do?

share|improve this question
    
is sudo apt-get update is completing successfully? and what version of ubuntu are you using. I suspect you are using a old version for which the packages are not listed. –  Web-E Jun 25 '12 at 7:16
    
you can see in this ppa gcc 4.7 only exist for precise not in oneric launchpad.net/~ubuntu-toolchain-r/+archive/… –  Web-E Jun 25 '12 at 7:19
    
Try rebooting and do sudo apt-get update and try installing them again. Also can you post your lsb_release -a output here. –  atenz Jun 25 '12 at 7:25

1 Answer 1

Can you please try this

sudo apt-get install build-essential

share|improve this answer
    
Please do not use the same answer for multiple questions. Also, this answer is more like a comment, because you are asking a question in an answer. –  RolandiXor Apr 12 '13 at 19:16
2  
Sorry about that @RolandiXor. I gave the same answer to two questions which were similar. I ll put this kind of suggestion in comment next time onwards... –  thefourtheye Apr 13 '13 at 5:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.