Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an old clunker - Dell Inspiron 1100 with A32 BIOS. I managed to install correctly from a USB drive, and the screen showed graphics in full natice 1024 x 768 - as did the 'try from USB' Ubuntu option. Once I committed to a full install on the HDD, the video resolution comes up as 640 x 480 with no other resolutions to change to full screen. Does anyone have some advice to allow the full LCD panel to be used?

Thanks for reading Ed

share|improve this question

3 Answers 3

Ubuntu and Dell Inspiron 1100

Change Video Memory in BIOS setup: Make sure your Dell Inspiron 1100 notebook has been upgraded to the A32 BIOS. When you start your computer, hit F2 to enter Setup. Press Alt-P (Turn the page) until you get to the page with the video memory (might be page 6, and might be listed as UMA (it’s actually “VMA”) size). Change the video memory from 1MB to 8MB. Reboot.

Once you've installed Ubuntu and you reboot, press Escape at the GRUB loader (it's the screen right after your bios initializes). Ubuntu Karmic (9.10) and higher will need to press and hold the left Shift key instead of Escape. Press e to edit the first kernel displayed. Find the line ending with "quiet splash". Add your boot option before these key words - i.e. so the line looks like ..."nomodeset quiet splash". Then press CTRL + X to boot.

To permanent this to GRUB2, you should add this option to /etc/default/grub, from a command prompt (terminal):

sudo gedit /etc/default/grub

The suggested options that I have found are hardware specific. Here is a list:

  • Older Intel video card: i915.modeset=1 or i915.modeset=0
  • nVidia: nomodeset
  • Generic: xforcevesa

Then add "i915.modeset=0" to GRUB_CMDLINE_LINUX_DEFAULT:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=0"
GRUB_CMDLINE_LINUX=""

Save your changes and you should get proper graphics on each reboot after doing:

sudo update-grub

To fully utilize the graphics, you also need to tweak xorg.conf:

sudo gedit /etc/X11/xorg.conf

Here is an example of what you should consider/what I have in mine, everything might not be needed/be legacy:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#

Section "Module"
    Load    "GLcore"
    Load    "i2c"
    Load    "bitmap"
    Load    "ddc"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "type1"
    Load    "vbe"
EndSection

Section "Device"
    Identifier  "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
    Driver      "i810"
    BusID       "PCI:0:2:0"
EndSection

Section "Monitor"
    Identifier  "Generic Monitor"
    ModelName   "Dell 1024x768 Laptop Display Panel"
    Option      "DPMS"
        HorizSync   31.5-48.5
    VertRefresh 59-75
EndSection

Section "Screen"
    Identifier  "Default Screen"
    Device      "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
    Monitor     "Generic Monitor"
    DefaultDepth    24
    SubSection "Display"
        Depth       1
        Modes       "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth       4
        Modes       "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth       8
        Modes       "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth       15
        Modes       "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth       16
        Modes       "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth       24
        Modes       "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier  "Default Layout"
    Screen      "Default Screen"
EndSection

Section "DRI"
    Mode    0666
EndSection

# End /etc/X11/xorg.conf

I also strongly recommend running Unity 2D on this machine. At login prompt, click on the Ubuntu logo after your name and choose "Ubuntu 2D".

I also recommend making the icons smaller: http://www.liberiangeek.net/2012/06/resize-unity-2d-launcher-in-ubuntu-12-04-precise-pangolin/

After all this, you should now be able to reboot into your nicely working Ubuntu installation. Enjoy!

share|improve this answer

I am trying to get this working with Ubuntu 13.04 and have been going crazy, nothing is consistently working!

I tried the suggested settings of:

nomodeset
i915.modeset=0
i915.modeset=1

The nomodeset would boot into a working graphical screen about 1 time in every three reboots. The others wouldn't work at all.

Finally, I changed the settings to explicitly set the VGA mode at boot and have yet to have a failure!

This is my configuration from /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off vga=792"

Remember to run the update-grub after making the change.

(more information on the Linux Video Modes: http://en.wikipedia.org/wiki/VESA_BIOS_Extensions#Linux_video_mode_numbers )

Best of luck!

share|improve this answer

After going through these instructions very carefully and not getting the desired result I found this to work much better.

Instead of changing the version of grub in the /etc/default folder, I had to change it in the boot/grub folder and make sure the quotes (") are included in that location. Also, the =1 worked rather than the =0 so it should read as:

"quiet splash i915.modeset=1"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.