Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this desktop:

i7 2600, 8gb ram ddr3, board intel dh61ww, Geforce Nvidia GT520-cn 2Gb ddr3,

I just installed Ubuntu 12.04 64-bit (kernel 3.2.0-23-generic). I want to setup two Samsung 22" LED monitors and get my video card drivers working.

  1. I downloaded and installed Nvidia driver 295.59. I tried the following with that driver and also with 302.17.

    I ran these commands:

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install build-essential linux-headers-$(uname -r),
    sudo apt-get remove --purge nvidia*,
    sudo apt-get remove --purge xserver-xorg-video-nouveau
    vim /etc/modprobe.d/blacklist.conf
    

    In the vim text editor, I added the following lines to blacklist.conf:

    blacklist vga16fb
    blacklist nouveau
    blacklist rivafb
    blacklist nvidiafb
    blacklist rivatv
    

    Then I ran these commands:

    sh NVIDIA.run
    sudo service lightdm start
    

    I rebooted, and after rebooting ran:

    nvidia-xorgconf
    
  2. After reboot I got a screen resolution of 800x600. I ran nvidia-settings and it said:

    You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

3) I changed xorg.conf slightly to set up a resolution to work property.

4) I don't have any image on my monitor and I dont have any option in the Nvidia X server settings.

$ lspci | grep VGA 
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 520] (rev a1)

$ egrep -i 'glx|nvidia' /var/log/Xorg.0.log

[    12.005] (II) LoadModule: "glx"
[    12.005] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    12.575] (II) Module glx: vendor="NVIDIA Corporation"
[    12.585] (II) NVIDIA GLX Module  302.17  Tue Jun 12 16:22:45 PDT 2012
[    12.585] (II) Loading extension GLX

[    13.037] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

[    13.044] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event10)
[    13.044] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event9)

$ glxinfo | grep direct 
Xlib:  extension "GLX" missing on display ":0.0". Error: couldn't find RGB GLX visual or fbconfig

What can I do to fix this and get video working on my Ubuntu system?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.