Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried Windows 8 Consumer Preview a couple months ago and it wiped out my partition table... or the boot information.

So now the machine cannot boot to anything at all. Is there Ubuntu tools or Linux tools that can fix all the partitions and make them boot again? (The partitions have Windows 7 and Vista on them. I run Ubuntu as a VM on Win 7). I tried another tool running on Vista and was able to see the Win 7 partition, except that tool wiped out the Vista boot info later on.


update: per @mlt's request, this is what fdisk -l says;

ubuntu@ubuntu:~$ sudo fdisk -l /dev/sda

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x1aca8ea5

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1       284993226   350602558    32804666+   7  HPFS/NTFS/exFAT
share|improve this question

1 Answer 1

First of all, I'm pretty sure unless you've asked Windows 8 installer to do otherwise, your partitions are fine. You've lost only a bootloader or boot configuration (which is a bit worse). You did not describe what exactly happens when you try to boot of your hard drive. Any specific messages on screen? Does your system use MBR or GPT? Does it have UEFI or legacy BIOS?

You'd be better off recovering your windows stuff using windows tools like DiskPart, bcdedit, and bootsect using recovery CD or any "Windows Live CD" alike tools. bcdedit allows you to edit boot configurations. Even reader is not there yet on linux.

If you are using MBR, you can give a try to restoring it. Though it may be not enough but you may be lucky. With GPT things are probably worse.

share|improve this answer
    
when booting, it says "NO boot media" or something... as if no OS is on the hard drive at all... so now I can't boot to anything... the only solution might be to boot to any DVD-R that can fix the issue. I think it uses MBR as it was a Vista machine to begin with... it was a 2008-09 HP Touchsmart IQ504... not sure if it has UEFI or BIOS? –  動靜能量 Jun 25 '12 at 3:55
    
What is the output of sudo fdisk -l /dev/sda (provided /dev/sda is your hard drive) once you boot off some Live CD linux distro? You might be simply missing a boot flag on your partition. –  mlt Jun 25 '12 at 4:01
    
so I think I can download the current Ubuntu and boot it up using the DVD-R and do the sudo fdisk? Just to make sure, it is -l, not -1... so I will make the disc and do that now –  動靜能量 Jun 25 '12 at 4:13
    
hi @mlt, I put the info in the original question –  動靜能量 Jun 25 '12 at 5:59
    
It looks like you do have a legacy BIOS. Your the only partition is not marked as bootable/active. You can use activate to make it active. Perhaps it is all that is missing. If you don't have that tool installed, you can do it with fdisk as well. See this as well. –  mlt Jun 25 '12 at 6:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.