Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hej

When I close my lid on my Lenovo SL500 laptop with in-built webcam, my computer goes on standby. When I start up again the webcam light turns on - for no reason.

I've found a way to make the light turn off again; starting cheese webcam (or probably any other webcam using program) then the light turns off for a second and goes back on, and the program shows camera video. When I close the program the light turns off as well.

Can anybody tell me if my computer is actually turning on the webcam or just the light? and what can I do to solve this problem?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

It is a known bug, and I have the same problem.

Bug report (not mine): https://bugs.launchpad.net/ubuntu/+bug/566205


Maybe try echo 'SUSPEND_MODULES="uvcvideo"' | sudo tee /etc/pm/config.d/modules_unload? Taken from https://bugs.launchpad.net/ubuntu/+source/linux/+bug/254825

share|improve this answer
    
what will happen when i type this in? –  Stenen Dec 2 '10 at 10:03
    
It will add the line SUSPEND_MODULES="uvcvideo" to /etc/pm/config.d/modules_unload. It tells the system to treat the module in a special manner, hopefully fixing the problem. –  evgeny Dec 2 '10 at 10:26
    
i think it works :-) thanks –  Stenen Dec 3 '10 at 8:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.