Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

We try to submit our application for the ubuntushowdown contest, but when we do the command : quickly submitubuntu, the application is not submitted, we have errors such as "build failed". We spend time about reading the log, but we are stuck, we don't know much about launchpad, can you explain us this error ? You could find the log here

Thanks for your help.

share|improve this question
    
possible duplicate of Launchpad failed to build after "quickly submitubuntu" –  Florian Diesch Jul 7 '12 at 14:15
add comment

2 Answers 2

up vote 1 down vote accepted

I believe you are missing a build dependency to supply the missing program.

It appears that you could add the package libglib2.0-bin to your build dependencies to make the program glib-compile-schemas available at build time. Apparently the program is used with Gsettings. The launchpad build process installs just the most basic packages, build dependencies declared in your debian/control file, and their dependencies, before trying to do the build.

If a build dependency is missing from the debian/control file an error is supposed to result as an aid to getting the build-dependencies correct.

To answer this, I noted the missing file, entered the command locate glib-compile-schemas and whereis glib-compile-schemas to find the missing file, and executed the command dpkg -S glib-compile-schemas to find the name of the missing package.

If you don't want to compile schemas as part of the build process you will need to adjust the build process by changing debian/rules or the packages make files.

share|improve this answer
    
thank you for your reply, but we had this to our control file, but it still doesn't work because this commande replace the file content. –  Audrey-ShowMyFaves Jun 26 '12 at 20:50
add comment

There is a fix for this problem? I want to publish my app but I still have this error, even if I try to insert libglib on the dependencies

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.