Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The pangolin has struck again. The bug of the day for today is Ubuntu taking away my permissions on my Data partition (NTFS). One moment everything worked fine, the next moment I couldn't chmod anything anymore. chown throws no errors or warnings at all, but nothing has changed either. chmod keeps saying Operation not permitted.

I've been messing around with /etc/fstab as suggested by other answers on AskUbuntu, but none of them seem to have the desired effect.

This is my current line:

UUID=25D7D681409A96B7 /media/Data     ntfs    defaults,umask=000,gid=46,permissions,users,auto,exec 0       0

For reference, this is the original one:

UUID=25D7D681409A96B7 /media/Data     ntfs    defaults,umask=007,gid=46 0       0

(right after the problem started occuring)

What do I need to do so I am the owner of my own hard drive again? I want to be able to just use chmod and chown (without sudo) without being told that some mysterious alien has taken over control of my Data partition.


I can still read and write, but execution permissions seem to be the problem.

--

I already figured out the execution permissions problem. The bounty's for the one who can tell me how I can set myself as owner of the data on that partition.

share|improve this question
    
Just for the record, sometimes the problem is not a bug; it could very well also be a previous bug that was fixed, making your formerly incorrect setting not work now. I don't know if this is the case, but as a programmer with 20+ years professional experience, assuming is the first step to failure in debugging. Do you want the owner & group to be you? That's how mine is set up, and it's a lot different than yours; I'm no expert, but I once spent a bit of time getting it right (for me, at least). –  Marty Fried Jun 24 '12 at 19:25
    
Do you only want to be able to execute files on ntfs partition? –  Anwar Shah Jun 27 '12 at 13:40
    
@AnwarShah Basically, yes. If possibly, I'd also like to be owner of the partition. –  RobinJ Jun 27 '12 at 14:01
add comment

2 Answers 2

up vote 3 down vote accepted
+50

If you wanted to mount ntfs partition and don't mind to use terminal, use the following method. This give you execution permission.

Mount the ntfs partition from terminal

  • Open a terminal and type

    udisks --mount /dev/sda2 --mount-options umask=022  
    

    It will mount the partition with execution permission. Remember, to replace the sda2 with your system partition number. You can check which partition you want to mount by executing this command sudo blkid.

Automatically mount ntfs partition at startup

If you want to mount the partition at startup with /etc/fstab add these options

  • Change the umask in /etc/fstab to 022. And add uid=1000 and gid=1000, assuming that your uid and gid values are 1000. The options will be now

    UUID=25D7D681409A96B7 /media/Data  ntfs-3g defauts,uid=1000,gid=1000,umask=022  0  0  
    

    Replace the values according to your partition UUID and suitable mount points.

Please note that, If you mounted your file system during boot time with /etc/fstab , you will not be able to unmount the drive without being root. If this is not your liking, you can use the below method which mounts at login

Automatically mount ntfs partition on login

  • Open Startup Applications by typing "Startup Applications" in the dash. Click on the corresponding icon to open it.
  • Then click on the "Add" button, type a name for the Action and in the command box, type the above command
  • Logout and Login again, to see your ntfs partitions mounted with execution permission.

enter image description here

Hope this will answer your question


share|improve this answer
    
Sometimes I don't login to my desktop, and just switch straight to the terminal. So I prefer to use /etc/fstab ;) However, I could probably just put that umask in there. –  RobinJ Jun 27 '12 at 14:29
    
Yep, pasting it in /etc/fstab worked. Maybe you should include that in your answer, for other users with the same problem. –  RobinJ Jun 27 '12 at 14:32
    
can you consider this as an answer? –  Anwar Shah Jun 27 '12 at 14:37
    
Startup applications is not the correct method for mounting disks. /etc/fstab is. –  RobinJ Jun 27 '12 at 14:43
    
Wait wait wait this isn't right. Now I've got execution permissions but no writing permissions anymore >.< –  RobinJ Jun 27 '12 at 14:49
show 3 more comments

I was having similar problems, not being able to execute shell scripts stored on NTFS, even with sudo, even after editing fstab as described above.

It turns out I had never made the mount point directory. I unmounted the partition, made the mount point directory for the Windoze7 partition:

mkdir /media/Windoze7

and then mounted again.

sudo mount -a
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.