Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have vmware palyer 4.0.3 installed on ubuntu 12.04 with kernel 3.3.6.

For some reasons the network doesn't work on it ( maybe because of the kernel) I tried to uninstall the vmware player using wmware-installer -u vmware-player but it failed.

This is what I get in the dialog:

The vmware installer could not shut down all running virtual machines. if you have ACE VMs open, please shut them down or suspend them now and press 'Retry' to continue.

I don't have any vm running and I tried to use serive command to stop but it failed again with this error:

bamdad@laptop:~/Software/patch$ sudo service vmware stop
Stopping VMware services:
VMware Authentication Daemon                                        done
/etc/init.d/vmware: line 351: [: 16519574018620477093: integer expression expected
VM communication interface socket family                           failed
Virtual machine communication interface                            failed
Virtual machine monitor                                            failed
Blocking file system                                                done
ERROR: Module vmnet is in use by [permanent]

I searched for custom patches and found nothing. I have no idea what else I can do to uninstall this vmware and install another one.

Please help

Bamdad

share|improve this question
    
Have you tried this procedure from the VMware KB for manually uninstalling it? –  Marty Fried Jun 24 '12 at 17:33
    
@MartyFried i tried but I can't stop the service using /etc/init.d/vmware stop –  Bamdad Dashtban Jun 24 '12 at 17:36
    
@MartyFried same result –  Bamdad Dashtban Jun 25 '12 at 11:20
    
@MartyFried The instructions say to use sudo su -, which is not the same as sudo su. sudo su - is essentially equivalent to sudo -i, whereas sudo su is essentially equivalent to sudo -s. It would be worth trying sudo su - or sudo -i. (See man sudo and man su for details.) –  Eliah Kagan Jun 25 '12 at 11:21

1 Answer 1

I couldn't figure out what was still running, my solution was taken from the VM Knowledge Base.

From the Section 6 "Remove the VMware startup scripts" we know where all startup scripts are located. Simply remove them all, and then restart your machine. On my Ubuntu box it was # rm /etc/rc{2,3,4,5}.d/*vmware*. Nothing related to VMWarewill be running.

After that I was able to run vmware-installer --uninstall-product vmware-workstation. Or enter whatever you're going to uninstall.

This solution isn't a clean one, but it worked for me. It simply lasted to long to figure out which process was using kernel modules or which files where still open.

share|improve this answer
    
+1 This also works for VMware Workstation 9 –  Benny Mar 25 at 17:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.