Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two keyborad keys, "Back" and "Forward". Forward works like it should, here is the output from xev for it:

KeyPress event, serial 36, synthetic NO, window 0x4600001,
    root 0x175, subw 0x0, time 16491048, (21,-17), root:(771,35),
    state 0x10, keycode 167 (keysym 0x1008ff27, XF86Forward), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 36, synthetic NO, window 0x4600001,
    root 0x175, subw 0x0, time 16491272, (21,-17), root:(771,35),
    state 0x10, keycode 167 (keysym 0x1008ff27, XF86Forward), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

Back on the other hand gives this from xev

FocusOut event, serial 36, synthetic NO, window 0x4600001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 36, synthetic NO, window 0x4600001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 36, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

Can someone help me make Back work? I don't understand why X generats Focus events for it..

share|improve this question
    
Did you try to change the shortcut settings? gnome-control-center > keyboard > shortcut... –  AndAC Jun 24 '12 at 16:29
    
Thank you AndAC, I managed to solve the Issue, back was assigned to Search in the shortcut settings... I don't know why, but after I removed that, the keypress event works correctly :D –  Adi Jun 24 '12 at 17:45
add comment

1 Answer 1

up vote 1 down vote accepted

The problem was that the key "Back" was assigned to the action "Search" in the gnome-control-center > keyboard > shortcuts.

I removed the shortcut and now the keypress event for "Back" gets generated in X. I guess gnome captures the keys when assigning them to a shortcut and prevents events from being generated.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.