Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have created a package with Quickly and also i have uploaded it to a brach on launchpad, but how can i create a ppa for that program and upload to it? i'm really new to these stuff, i just learned how to use bazaar.

How do i add/create a <source.changes> file?

jeggy@jeggy-XPS:~/Skriviborð/jebster$ dput ppa:jeggy/jebrowser
Not a .changes file.
Please select a .changes file to upload.
Tried to upload: ppa:jeggy/jebrowser

I have added a OpenPGP key if that helps in anyway.

To response to andrewsomething:

jeggy@jeggy-XPS:~/Skriviborð/jebster$ quickly share --ppa ppa:jeggy/jebrowser
Get Launchpad Settings
Launchpad connection is ok
gpg: WARNING: unsafe permissions on configuration file `/home/jeggy/.gnupg/gpg.conf'
gpg: WARNING: unsafe enclosing directory permissions on configuration file `/home/jeggy/.gnupg/gpg.conf'
gpg: WARNING: unsafe permissions on configuration file `/home/jeggy/.gnupg/gpg.conf'
gpg: WARNING: unsafe enclosing directory permissions on configuration file `/home/jeggy/.gnupg/gpg.conf'
User or Team ppa:jeggy not found on Launchpad
ERROR: share command failed

When i run debuild -S -sa i get this

jeggy@jeggy-XPS:~/Skriviborð/jebster$ debuild -S -sa
 dpkg-buildpackage -rfakeroot -d -us -uc -S -sa
dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): -D_FORTIFY_SOURCE=2
dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions -Wl,-z,relro
dpkg-buildpackage: source package jebster
dpkg-buildpackage: source version 0.1
dpkg-buildpackage: source changed by root <root@jeggy-XPS>
 dpkg-source --before-build jebster
 fakeroot debian/rules clean
dh clean --with python2,translations
running clean
'build/lib.linux-x86_64-2.7' does not exist -- can't clean it
'build/bdist.linux-x86_64' does not exist -- can't clean it
'build/scripts-2.7' does not exist -- can't clean it
WARNING: the following files are not recognized by
 dpkg-source -b jebster
dpkg-source: warning: no source format specified in debian/source/format, see dpkg-source(1)
dpkg-source: warning: source directory 'jebster' is not <sourcepackage>-<upstreamversion> 'jebster-0.1'
dpkg-source: info: using source format `1.0'
dpkg-source: info: building jebster in jebster_0.1.tar.gz
dpkg-source: info: building jebster in jebster_0.1.dsc
 dpkg-genchanges -S -sa >../jebster_0.1_source.changes
dpkg-genchanges: including full source code in upload
 dpkg-source --after-build jebster
dpkg-buildpackage: source only upload: Debian-native package
Now running lintian...
E: jebster changes: changed-by-address-malformed root <root@jeggy-XPS>
W: jebster source: diff-contains-bzr-control-dir .bzr
W: jebster source: unused-build-dependency-on-cdbs
W: jebster source: package-needs-versioned-debhelper-build-depends 8
W: jebster source: ancient-standards-version 3.8.3 (current is 3.9.3)
Finished running lintian.
Now signing changes and any dsc files...
 signfile jebster_0.1.dsc root <root@jeggy-XPS>
gpg: WARNING: unsafe enclosing directory permissions on configuration file `/home/jeggy/.gnupg/gpg.conf'
gpg: WARNING: unsafe enclosing directory permissions on configuration file `/home/jeggy/.gnupg/gpg.conf'
gpg: skipped "root <root@jeggy-XPS>": secret key not available
gpg: /tmp/debsign.BdtFRCql/jebster_0.1.dsc: clearsign failed: secret key not available
debsign: gpg error occurred!  Aborting....
debuild: fatal error at line 1271:
running debsign failed


jeggy@jeggy-XPS:~/Skriviborð/jebster/debian$ cat changelog
jebster (0.1) precise; urgency=low

  [ Jógvan Olsen ]
  * Initial release.

  [ root ]

 -- root <root@jeggy-XPS>  Mon, 25 Jun 2012 14:53:00 +0100

jeggy@jeggy-XPS:~/Skriviborð/jebster/debian$ gpg --list-keys
gpg: WARNING: unsafe enclosing directory permissions on configuration file `/home/jeggy/.gnupg/gpg.conf'
pub   2048R/1C17B342 2012-03-10
uid                  Ubuntu Accomplishments <>
sub   2048R/6305AA1F 2012-03-10
sub   2048D/05164E07 2012-03-10

pub   1024R/2868F9C3 2012-06-23
uid                  Jógvan Olsen <>

pub   2048R/5C24B331 2012-06-24
uid                  Jógvan Olsen <>
sub   2048R/162F6987 2012-06-24

pub   2048R/2B4F8FE7 2012-06-26
uid                  Jogvan Olsen <>
sub   2048R/9CF57E08 2012-06-26
share|improve this question
Can you cd into your source directory, run debuild -S -sa, and include the output in your question? – izx Jul 2 '12 at 16:34
Thanks! Please post the content of the debian/changelog file inside your jebster directory; as well as the output of gpg --list-keys – izx Jul 3 '12 at 2:19
up vote 7 down vote accepted

OK, we need to get you ready using the usual PPA process (forget this Quickly business, it seems to be going Slowly ;)

Forgive me for using your full name jeggy, but it's in your Launchpad account so not exactly secret:

  1. Sign the Code of Conduct

  2. Set your name and modify the changelog, correctly:

    • E: jebster changes: changed-by-address-malformed root <root@jeggy-XPS>
    • This is a problem, because your (a) it is in the wrong format, and (b) has no relation to your GPG key.
    • In the terminal, set these variables:
      export DEBFULLNAME="Jógvan Olsen"
      export DEBEMAIL=""
    • Now open the changelog (debian/changelog) in gedit; carefully select only this signature at the end:
      root <root@jeggy-XPS> and change it to
      Jógvan Olsen <> making sure spaces before/after are not affected.
    • The final changelog should look something like:
      jebster (0.1) precise; urgency=low
      * Initial release.
      -- Jógvan Olsen Tue, 03 Jul 2012 04:29:33 -0700
  3. Finally, debuild and correctly sign the source.changespackage

    • Run debuild -S -sa, and this time you should be asked to sign with your GPG key, 5C24B331

    • cd .., and then dput ppa:jeggy/jebster xxxxxxx_source.changes

share|improve this answer
I keep getting this error when trying to sign up for the code of Conduct… – Jeggy Jul 3 '12 at 13:23
OK, that's a messy keyring :p. Im not in front of a computer, but if you aren't using the 1024 key, can you delete it with gpg --delete-secret-key 2868F9C3, and then try the CoC again -- this time with the `-u "Jógvan Olsen" additional option to gPg if necessary? – izx Jul 3 '12 at 13:37
@Jeggy, that error definitely appears to be caused because GPG defaults to the first key, 1024/2868F9C3, and that does not have a pub key associated with it. Deleting it as specified in the previous comment should help... – izx Jul 3 '12 at 17:20
Thanks it works now – Jeggy Jul 3 '12 at 22:02
@Jeggy: I'm sorry, that's because of the -1 in 1.0.0-1 that I used as an example in the changelog; -N signifies a Debian revision, so it looks for the original source package. Please see edited answer, the first line/version should be jebster (0.1) precise; urgency=low – izx Jul 4 '12 at 14:34

.changes files are PGP signed files that describe the contents of a Debian source package, including Sha256 checksums of the different files and the changelog entry. It is generated when you build a source package, usually done by running debuild -S

But you don't need to worry about this! Quickly takes care of all this for you. Just run quickly share --ppa ppa:jeggy/jebrowser

share|improve this answer
Thanks, but it didn't work :( i added the output to the question – Jeggy Jun 25 '12 at 2:43

I think it is a problem of a setup of launchpad.

I saw your profile page on launchpad.

You can only activate a PPA if you have signed the Ubuntu code of conduct.
Do you activate "Signed Ubuntu Code of Conduct: yes"?

How to activate CoC is here:

How do I sign the Ubuntu Code of Conduct?

If you look already some wrong text and can't post new text, click Deactivate button. Please try again from the first.

Then you can see Signed Ubuntu Code of Conduct: yes on your profile page of Launchpad, try again the command:

quickly share --ppa jeggy/jebrowser

I rewrote the answer, in order to arrange a problem.

share|improve this answer
wow.. i thought i had done that.... but here's what i get when trying to. There is 1 error. (7, 9, u'No public key') – Jeggy Jun 28 '12 at 12:19
When you upload of CoC, did you use an SSH key? You have to use an OpenPGP key, not an SSH key. – vine_user Jun 28 '12 at 13:59
how do i choose? i have both SSH and PGP key's on launchpad. i just followed the instructions.. – Jeggy Jun 28 '12 at 14:43
I mistook this for the case of the file which was uploaded simply. In this case, SSH was not related. Please copy & paste the text enciphered by the GPG key. – vine_user Jul 2 '12 at 23:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.