Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new in using Linux. The problem I'm having is with the update manager. I have it pinned to the launcher but when i left-click it does not respond. When i right-click it it responds by showing me the menu but i don't want to install all the available updates. My laptop is a MSI CR630. I also have a problem with my wlan. It's saying that it is manually turned of but I tried everything i could think of but let's face it, I am noob. But I'm using linux for 2 months now and I don't want to go back to a cracked windows.

If you would like to help me with an answer please be as detailed as you can.

Thank you!

share|improve this question
    
It would be really good if you did these in two questions. Just my 2 cents :) –  Micheal Harker Jun 24 '12 at 12:55
    
I thought that the both of them are related somehow... –  Cristian Jun 24 '12 at 13:00
add comment

2 Answers

With the help of rfkill list i have managed to figure out that the hard unblocker was the combo of Fn + F8. As for the other problem, still not solved. I mean that when i have updates ready i can't load the interface with them listed. I click it but it doesn't load. But I am able to right click it and then click the option install all updates. Ideas anyone?

share|improve this answer
add comment

First of all, why do you not want to install the available updates? Updates are a good thing, and unless you know that updates will break compability you should apply them. You can apply all updates from a terminal instead of the update manager by running

sudo apt-get update && sudo apt-get upgrade -y

Secondly, please have a look at I have a hardware detection problem, what logs do I need to look into?, we need to know if your wireless card is detected at all. Has it worked before, or has it never worked?

If you help us get a more complete picture of your problem we can help you a lot quicker.

share|improve this answer
    
02:00.0 Network controller [0280]: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090] it has never worked before (i only sr=tarted working with linux when i boutght this laptop –  Cristian Jun 24 '12 at 13:30
    
*-network DISABLED description: Wireless interface product: RT3090 Wireless 802.11n 1T/1R PCIe vendor: Ralink corp. physical id: 0 bus info: pci@0000:02:00.0 logical name: wlan0 version: 00 serial: 6c:62:6d:19:38:b9 width: 32 bits clock: 33MHz –  Cristian Jun 24 '12 at 13:34
    
and it continues like this : capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=rt2800pci driverversion=3.2.0-25-generic-pae firmware=0.34 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn resources: irq:16 memory:fdfe0000-fdfeffff –  Cristian Jun 24 '12 at 13:35
    
Here's a thread by someone having problems with the same controller (ralink). Try searching here on askubuntu and on the ubuntu forums for things to try, for example rfkill list which is listed in the thread I linked can give you info on whether the interface is blocked or not. You know what controller you have now so just start googling :) also try the firmware-b43-installer package. –  bigbadonk420 Jun 24 '12 at 15:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.