Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install the Lexmark X1290 printer on a 64-bit Ubuntu 10.10 system. I previously had this printer working flawlessly on a 32-bit Ubuntu 10.04.

I'm following the instructions from http://www.trodrigues.net/wiki/linux:ubuntu:lexmark_x1290 and using the Z600 series driver from Lexmark.

Create a directory named lexmark and unpack the driver:

mkdir lexmark
tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz

Extract the driver from the install script:

tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz

And untar it:

tar -xvzf install.tar.gz

This generates 2 drivers (z600cups-1.0-1.i386.rpm and z600llpddk-2.0-1.i386.rpm) that then should be converted to .deb files with alien and installed with dpkg, but -as the filenames already indicate- the drivers are for 32-bit systems and not for 64-bit systems. Hence the error:

$ sudo dpkg -i z600cups_1.0-2_i386.deb 
dpkg: error processing z600cups_1.0-2_i386.deb (--install):
  package architecture (i386) does not match system (amd64)
  Errors were encountered while processing: z600cups_1.0-2_i386.deb

Any idea how I can get this to work?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I'm not familiar with this driver, but you could force the installation by running:

sudo dpkg --force-architecture -i z600cups_1.0-2_i386.deb

It might still not work, but it's worth a try.

share|improve this answer
    
This did indeed the trick! (a note to people in the same position and following the above mentioned tutorial: if you get a CUPS 'server-error-internal-error' after selecting the .ppd.gz, just gunzip and select the .ppd file.) –  BioGeek Nov 30 '10 at 17:29
    
PS: Oli, if you have an account on superuser and provide the same answer to the the question there: superuser.com/questions/216738/… I'll accept it as the correct answer there as well. –  BioGeek Nov 30 '10 at 17:32
    
Glad it worked and I've Answered that one too :) –  Oli Nov 30 '10 at 17:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.