Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The internal microphone on my hp mini 1001TU does not work with sound recorder or skype.

share|improve this question
    
Which Ubuntu release are you running? –  Mitch Jun 24 '12 at 11:31
    
Hi Mitch, im using 12.04 LTS 32 bit –  Peter Jul 3 '12 at 10:36
    
I did a clean install formatted the hard drive. I am not running dual boot, just ubuntu 12.04LTS –  Peter Jul 6 '12 at 22:46
add comment

2 Answers 2

Go to sound settings.

If you are using Unity, then type Sound in Dash.
If you are using an Older Version, then Select it from your Menu.

Select the Input Tab.

Under Record Sound from, select Internal Microphone.

It's settings will be shown on the right.

Make sure that Mute is not selected.

Hopefully, your Microphone should work fine now.

share|improve this answer
    
yes tried this, still no luck. I installed pulse audio volume control as well and did changes in that and still no luck –  Peter Jul 3 '12 at 10:40
    
Is Ubuntu the only OS? If your dual-booting, make sure your microphone is working in the other OS. –  Karthik Jul 3 '12 at 12:14
    
In the solution I gave above, under the mute checkbox, you should have an entry, saying something similar to "Adjust Volume". When you speak in your Microphone, are the bars getting filled up there? –  Karthik Jul 3 '12 at 12:17
    
Ubuntu 12.04LTS is the only OS on my netbook. It was a new clean install, hard drive formatted. –  Peter Jul 6 '12 at 22:45
    
when i adjust the volume control and speak into the mic, i dont see any of the bars getting filled. –  Peter Jul 6 '12 at 22:49
show 1 more comment

To get help, best one on this Alsa sound issue answers.launchpad.net/ubuntu...ce/alsa-driver Steps to get help.

  1. Register to the launchpad first
  2. Login
  3. Key in your question in the question box on the left upper conner.
  4. give it 1-2 days someone should come in and help.

I found this below method from here. It's similar to what I did here.

avinash.sridhar November 15, 2009 19:35

I have a mini HP mini 1030 NR and got my internal mic to work with the sound recorder as well as skype 2.1 beta.

Here's what I did: Preferences ->Sound -> Change everything to ALSA

edit /etc/modprobe.d/alsa-base.conf and add the follwing 3 lines to the end of the file

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp-m4 enable_msi=1

save and reboot.

Once rebooted , log in and click on the Volume Icon,click Volume Control , click under the Options tab, make both sources "Line" (i guess this is due to some mislabeling in the drivers ).

He has details tutorial too.
See if that will work for you.
If not, try to ask for help on Launchpad.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.