Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm Italian and so I apologize for my English! I'm a beginner to Ubuntu and I tried it on my desktop PC and it's fantastic, fast and fun!

I decided to try it on my netbook Packard Bell DOT M/A and this is the configuration:

  • AMD Athlon L110 1.2GHz
  • 2GB of RAM
  • ATI Radeon x1270 (RS690M)
  • 150GB Hard Disk

I installed Ubuntu 12.04 with Wubi (dualboot Windows 7 + Ubuntu 12.04), because the netbook does not have a DVD player!

During the installation everything is OK, after it was installed I see mistakes in the graphical display! I see objects that are seen in different colors and moving (buttons, mouse pointer, text bar ... etc ...) At one point came not to see anything, such as this screenshot:

enter image description here

The drivers are open, that is already installed in Ubuntu. Windows 7 video card runs fine, can run well Aero (transparent window effects), I can watch movies in HD and play some games with the Catalyst drivers from AMD. Now I ask a favor, you can help me solve this problem? Is there a fix for this driver or drivers different on the Internet? Thanks for your attention, good bye!

share|improve this question

4 Answers 4

up vote 2 down vote accepted

Lets get through some steps,

Please download the graphics driver form here

For installation see here ATI RS690m X1200 proprietary driver installation

Please make sure following libraries are installed

  • XFree86-Mesa-libGL
  • libstdc++
  • libgcc
  • XFree86-libs
  • fontconfig
  • freetype
  • zlib
  • gcc
share|improve this answer
    
In the terminal gives me an error: Error: ./default_policy.sh does not support version default:v2:x86_64:lib32::none:3.0.0-17-generic; make sure that the version is being correctly set by --iscurrentdistro.... How do I do? –  user72919 Jun 24 '12 at 12:42
    
make sure the libraries are installed. I personaly never had ati grphics card. Alternatively in software center search for fglrx ,, then install ATI binary X.Org driver from search result. –  Web-E Jun 24 '12 at 12:51

I have a Gateway L3103u Netbook with this exact same card and problem. The only fix I have ever found is by installing fglrx alongside the open source driver. While the card is not supported in the latest versions of Catalyst, the installation of the driver fixes whatever modeset is causing the buffer error (what I call the drawing of all of those lines).

Disabling modeset (with nomodeset) will also disable your ability to scale your framebuffer, but that might not be an issue for you.

share|improve this answer
    
nice. I have a LT3107. First tried nomodeset but that prevents ctrl+alt+F1-6 for console access. Installing fglrx worked perfectly. –  lambacck Nov 16 '12 at 2:54

I have the same netbook with the same problem.

The proprietary drivers wont work because they only work with kernel 2.6.28 and older.

ATI/AMD dropped Catalyst support for these cards in Catalyst 9-4. These cards are supported with the legacy ATI 9-3 Catalyst release, but you MUST use a kernel <= 2.6.28 and Xserver <= 1.5

So after a while, I found this.

You have to add nomodeset on GRUB_CMDLINE_LINUX_DEFAULT

sudo nano /etc/default/grub

find the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and change it to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

save the file and do

sudo update-grub

then reboot and you'll have your desktop.

The only thing that I can't find yet is how to enable the effects.

share|improve this answer

I'd suggest that you try Ubuntu from a Live USB just to see if this issue is still there when you run Ubuntu live or if it's something that appears when you install via Wubi. I know Wubi installs can be a bit dodgy sometimes, and issues might disappear if you actually do a "clean" install of Ubuntu on the hdd.

If you want to keep Windows, you can still choose this during the USB install and Ubuntu will create a separate partition for Ubuntu to use. Remember to backup all your data before experimenting with partitions, though!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.