Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Ubuntu 12.04 installed on my laptop. When I go to Sound Settings while logged into my user, no sound card appears detected.

In spite of this, the sound on my laptop is working ok, and I can use alsamixer just fine. The Unity sound indicator is dead, and this is quite annoying.

If I login as guest, the sound indicator works just fine, I assume it's something related to my user's sound settings, but I cannot find what exactly.

Any clues?

share|improve this question
If sound is coming in guest account, the sound card is already detected – Anwar Shah Jun 24 '12 at 13:45

I had the same problem on my MacBook Pro 8.1 running Ubuntu 12.04. I solved it by resetting pulseaudio user configuration as explained here.

You have to run the following lines in terminal

rm -r ~/.pulse*; pulseaudio -k

and then logout and log back in.

share|improve this answer

If you are referring to the problem that, You cannot select sound profile from the sound settings menu, then you can try the following method. I provided the answer in some questions. It works for me, so can also work for you.

Solution 1:

(It worked for me with Only S/PDIF profile, Sound from both headphone and speaker and not being able to switch profile)

  1. Add this ppa by the command

    sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
  2. Update packages list by

    sudo apt-get update
  3. Then install "alsa-hda-dkms" package:

    sudo apt-get install alsa-hda-dkms

Reboot, And See the result!

Solution 2

  1. Go to Realtek official site, accept the disclaimer, then download the audio driver for linux/unix. You need to select version 3 for Kernel 3 or later.

  2. Setup necessary tools to compile this driver.

    sudo apt-get install build-essential gcc make

  3. Extract the downloaded file, run sudo ./install file from a terminal after going to the extracted folder to compile the driver.

  4. Read the Readme.txt file for more information.

I had a problem with Sound settings in Ubuntu 12.04 (not being able to switch profile). It fixed now.

share|improve this answer
Solution 2 : Now I can't see my card in sound settings :( – Yugal Jindle Oct 12 '12 at 18:53

I have had this problem with 12.10 and looked all over. I finally found my answer here:

I modified /etc/default/grub, rebooted and voila!

Hope this helps.

share|improve this answer
Thanks for contributing this answer! It's generally helpful to quote the most relevant parts of a link (in this case, the instructions on the modification to make to /etc/default/grub) in case the target site is unavailable. – Andrew Johnson Dec 14 '12 at 23:50

In my case (Dell Latitude E4310 laptop) the problem was the following line in /etc/pulse/client.conf:

autospawn = no

I commented this out, and then ran

pulseaudio -k



and then the sound icon in the taskbar came back to life, and the volume up/down/mute buttons started working.

share|improve this answer

Install pulseaudio-module-udev

sudo apt-get install pulseaudio-module-udev
share|improve this answer
Why do you suggest it? Please do not post "it worked for me". – Pilot6 Jul 23 at 3:26
-1 That won't help. The PulseAudio setup is already working in the guest account, so installing another package won't change anything. – David Foerster Jul 23 at 14:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.