Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am re-purposing an old laptop. I installed 11.10 on it and then immediately upgraded to 12.04. (I could not directly install 12.04 as my system does not support PAE.)

When my system was (briefly) 11.10, the desktop appeared as expected. However, after the upgrade to 12.04, the icons in the launcher area are invisible. If I hover over the spot where the icon should be the little popup window showing the tool's name appears, and I can click to invoke the tool. I just cannot see the icons.

enter image description here

The icons do appear as expected in other contexts, for example in the Home folder and in Dash Home.

My theme is "Ambiance (default)"

I do not have a ~/.icons folder.

This is the top level contents of /usr/share/icons:

default
DMZ-Black
DMZ-White
gnome
handhelds
hicolor
HighContrast
HighContrastInverse
Humanity
Humanity-Dark
locolor
LoginIcons
LowContrast
redglass
ubuntu-mono-dark
ubuntu-mono-light
unity-icon-theme
whiteglass

(Sorry for the poor formatting, can't get it to show in list.)

I suspect that the launcher isn't looking for the icons in the right place, but I don't know how to confirm that, or how to correct.

This is my first foray into Linux, although I used to use Unix a few decades ago. This doesn't look much like my old Sun workstation, though!

Does anyone have any suggestions or insights for me? Thanks.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

1st try reset your unity by using this command

unity --reset

Rebuilt icon package

gsettings set org.gnome.desktop.interface icon-theme 'Unity-icon-theme' 

Other default icon package

gsettings set org.gnome.desktop.interface icon-theme 'Ubuntu-mono-dark' 

gsettings set org.gnome.desktop.interface icon-theme 'Ubuntu-mono-light' 
share|improve this answer
    
I have tried "uniti --reset". It made no difference. –  Clo Knibbe Jun 23 '12 at 21:28
    
I'll give the gsettings thing a try. Thanks. –  Clo Knibbe Jun 23 '12 at 21:28
    
Will I need to restart after doing gsettings? –  Clo Knibbe Jun 23 '12 at 21:32
    
nope... is there any different? i've update my answer, please try others. –  penreturns Jun 23 '12 at 21:34
    
I've tried all 3 gsettings. No change. –  Clo Knibbe Jun 23 '12 at 21:37

You can use

$ gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"    

For more help visit: http://noohonlinux.blogspot.in/

share|improve this answer
1  
The original question isn't about the systray, but the launcher. –  MadMike Oct 21 at 12:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.