Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to boot my lucid, with the built in boot shell giving out this error:
alt text Update 1
This error occured after I updated my 2.6.32-26 version kernel and booted directly in winodows.

The rootdelay solution did not work. Is there any chance that my disk's uuid got changed (maybe by windows), I could log in to my Ubuntu earlier but after logging into windows, and rebooting I get this error. As far as backing up is concerned, do I need to even if I have separate home and workspace partitions than Ubuntu installation?

Update 2
The update after which this happened was just an update (no new install) of version 2.6.32-26. So I guess this has something to do with last update of this version of kernel. Also since it was not a new install, no new menu entry was added. By any chance may this be caused because of my rebooting in windows after the kernel update.

Update 3
Installed older kernel by chrooting through live usb, still the same problem with the kernel. So it seems the problem is not due to kernel update after all.

I have faced this problem earlier too but back then, I just considered reinstalling distribution easier (I used to distro switch a lot). But now I had configured it too far and so looking for some last resort.

Update 4
Reinstalled buntu. Configuration was easier this time thanks to separate home and workspace partitions. Even tough I don't need the solution of this problem just now but if you know any possible solution please post here for future benefits.

share|improve this question
    
Try running "blkid" from the initramfs prompt to list recgonized device uids. –  João Pinto Nov 30 '10 at 15:09
    
What happens if you let the computer sit at the busybox "(initramfs)" prompt for a minute and then type "exit" and hit the Enter key? –  Li Lo Nov 30 '10 at 17:46
    
gives out the same prompt again, the above messages get appended to the boot shell –  crodjer Dec 1 '10 at 5:56
add comment

10 Answers

I fixed this myself editing the file /etc/default/grub

GRUB_CMDLINE_LINUX=" rootdelay=3 "
GRUB_DISABLE_LINUX_UUID=true

With only the first one, it was not enough. I even tried a 130 as stated before. Then I disabled UUID with the second command. It was a LVM root partition anyway, so the UUID data was pointless.

share|improve this answer
add comment

I had the same issue like the thread starter and I solved it without reinstalling.

My issue occurred while juggling with a virtual installation based on a copied disk image. This resulted in a changed uuid and the copy wouldn't start. This is a rough sketch of what i did.

First boot using a rescue system (same version) and run a shell on your non-booting disk. Have a look at /etc/fstab and confirm the uuids there by issuing the blkid command for each device. Fix these entries as they're important.

Next we fix grub with:

  • grub-mkconfig
  • update-grub

Then run:

  • update-initramfs -u /boot/initrd.img-2.6.YOURVERSION-HERE

This will create a fresh initramdisk for your version. If you don't know the exact version you were running have a look at the files in /boot/. Picking the highest version number should be safe.

After you exit the rescue shell the ubuntu live cd will offer you the last menu from where you entered the shell. Choose "install Grub" (or similar) there and enter the device where to put your boot sector.

On most systems (standard install) /dev/sda is a safe bet. Be aware: Windows- or other multiboot-systems might need other entries here!

Finally you should be able to boot from the repaired disk.

share|improve this answer
add comment

How to Fix an Ubuntu Error: "No init found. Try passing init= bootarg"

This morning, a friend came to me with his laptop that won't boot. At every boot attempt, his Ubuntu 10.04 Lucid Lynx system outputs the following error messages:

mount: mounting /dev/disk/by-uuid/***************************** on /root
failed: Invalid argument
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target file system doesn't have /sbin/init
No init found. Try passing init= bootarg



Busybox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu7) built-in shell (ash)
Enter 'help' for a list of built-in commands
(initramfs) _

Booting into "Recovery Mode" as well as choosing the other kernels listed in grub didn't help at all.

Solution:

  1. Boot from the Ubuntu Live CD;

  2. Open/Run Terminal;

  3. Type: sudo fdisk -l (to get the device name) then press ENTER;

    Disk /dev/sda: 250.1 GB, 250059350016 bytes 255 heads, 63 sectors/track, 30401 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Disk identifier: ****

    Device Boot Start End Blocks Id System /dev/sda1 * 1 30238 242886703+ 83 Linux /dev/sda2 30239 30401 1309297+ 5 Extended /dev/sda5 30239 30401 1309266 82 Linux swap / Solaris

The device name for my friend's system based on the above: /dev/sda1

  1. Type: sudo fsck /dev/sda1 then press ENTER;

  2. Restart the system and boot normally.

    • The laptop booted normally after the fix.
share|improve this answer
add comment

This issue appeared for me after installing libuuid. I was able to fix it manually and now it boots OK, but every time it still shows errors about missing blkid. Also, boot failure re-appears after updates that require rebooting.

The UUID in the /proc/cmdline is correct, however system fails to recognize it.

share|improve this answer
add comment

When I saw this on my system, it was a matter of the wrong UUID being set as the boot root parameter in /boot/grub/menu.lst .

cat /proc/cmdline actually shows the boot parameters passed to initramfs -- if you see that initramfs is being told to mount a non-existent root partition, it's obviously going to fail.

update-grub did not update these parameters for me, but simply doing a manual replacement for the old UUID in the menu.lst fixed it for me.

share|improve this answer
    
This is also how I've had to fix things in the past. However, last time I didn't even bother with the UUID and just replaced the incorrect UUID with the /dev/xxx device id in /etc/fstab. For others trying to fix this, also see @loevborg's answer. –  belacqua Sep 13 '11 at 3:37
add comment
up vote 1 down vote accepted

Tried all the answers but could not solve it so finally hadd to reinstall ubuntu :(.

This same error came in my friends comp too, but he had no luck with it too.

share|improve this answer
add comment

I dont have any idea of what can cause this but as a solution you can try reinstalling Grub only. I think it will solve your problem.

share|improve this answer
1  
I chrooted and tried this too but didn't work...finally I reinstalled the distro. –  crodjer Dec 1 '10 at 14:46
add comment

Have you got an older kernel? Does it work? Check /etc/fstab as loevborg said about possible 'stale' records (i had the same problem when installed lvm and grub2 - there was an old record for /boot partition which caused the error)

share|improve this answer
    
no....I have a habit of deleting old kernel after testing a new install 4-5 times. The update after which this happened was just an update (no new install) of version 2.6.32-26. So I guess this has something to do with last update of this version of kernel. –  crodjer Nov 30 '10 at 17:13
    
Why don't you try to chroot with a live cd and reinstall this kernel or the latest 2.6.35-23? –  Pavlos G. Nov 30 '10 at 17:30
    
yeah.....currently making a live usb stick –  crodjer Nov 30 '10 at 17:53
    
Installing old kernel did not work either....the problem doesn't seems to be because of the kernel update after all. –  crodjer Dec 1 '10 at 6:03
    
Can you then try to run bootsinfoscript (sourceforge.net/projects/bootinfoscript) and paste the results here? –  Pavlos G. Dec 1 '10 at 9:09
add comment

As a matter of fact I have experienced disk UUIDs changing spontaneously once or twice. The change may be the result of a corruption of some sort. I would try the following:

  • Boot your computer from a live medium;
  • fdisk -l /dev/sda to find the partition you're looking for; or use cfdisk; or usegparted(replacesda` by your hard drive).
  • blkid /dev/sda1 (replace sda1 by the partition you found); alternatively use vol_id;
  • see if you can mount the partition (using the device file /dev/sda1);
  • check if the UUID displayed matches with the UUID in your root partition's /etc/fstab;
  • generate a new UUID using uuidgen and apply it to the partition using tune2fs -U;
  • change the fstab entry accordingly.

It might seem unlikely that something as vital as the UUID changes without apparent cause, but it happens, probably because of a bug. See if changing the UUID to a new value helps.

share|improve this answer
1  
The uuid in the initramfs prompt, root disk and fstab were same. I still changed it as you specified but still the same problem –  crodjer Dec 1 '10 at 6:52
    
Maybe this really is a problem related to the kernel update. Can you mount the file system from inside the busybox shell? Try mounting it using the device file /dev/sda1 (mutatis mutandis), which shouldn't be related to the UUID at all. If that works, you can just edit your fstab and GRUB configuration to use device files rather than UUIDs. –  loevborg Dec 1 '10 at 10:15
    
Also, about re-installation - it's not that big of a deal if you make a copy of your /home directory and drop it in after installation. Then it's just about installing the same set of packages (which can be done automatically as well). I agree that it shouldn't really be necessary and it's much cleaner to find the problem instead, though. –  loevborg Dec 1 '10 at 10:18
add comment

The problem seems to be that your hard disk, or the controller, doesn't respond quickly enough.

Try the following:

  • When the boot menu comes up, having the top of the list highlighted, press e (for edit).

  • You should see a long list of parameters. Add this one to it: rootdelay=130

  • Hit Enter and then b (boot). Try to see if you system boots now. You can increase the value if that doesn't help first time (but not by much, 130 is already more than enough for any hardware that isn't broken).

However, it may also be your hard drive is failing. The first thing to do once you get back into your system is backing up your data. If you want to be safe, back it up using an ubuntu cd. I strongly urge you to do that, sooner rather than later.

share|improve this answer
1  
This is true... what ever happens, try a live CD or live USB and after you boot to the live desktop attach an external hard drive (hope you have one) and start backing up your data to the external hard disk... –  Salih Emin Nov 30 '10 at 14:39
    
the rootdelay solution did not work. Is there any chance that my disk's uuid got changed (maybe by windows), I could log in to my buntu earlier but after logging into windows, and rebooting I get this error. As far as backing up is concerned, do I need to even if I have separate home and workspace partitions than buntu installation? –  crodjer Nov 30 '10 at 14:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.