Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
$ sudo apt-get install cinnamon cinnamon-session cinnamon-settings
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'cinnamon' instead of 'cinnamon-session'
Note, selecting 'cinnamon' instead of 'cinnamon-settings'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 cinnamon : Depends: gir1.2-muffin-3.0 but it is not going to be installed
            Depends: libcogl5 (>= 1.7.4) but it is not installable
            Depends: libmuffin0 (>= 1.0.0-0ubuntu1~precise) but it is not going to be installed
            Recommends: gnome-themes-standard but it is not going to be installed
            Recommends: gnome-session-fallback but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I added this PPA:

sudo add-apt-repository ppa:merlwiz79/cinnamon-ppa

Then ran the following command:

sudo apt-get update && sudo apt-get install cinnamon cinnamon-session cinnamon-settings

How can I install the latest Cinnamon desktop? How can I fix this error?

share|improve this question

3 Answers 3

This is a package dependency problem.

Type these in the terminal:

sudo apt-get install gir1.2-muffin-3.0 libcogl5 libmuffin0

and reboot and then install Cinnamon.

If you still can't install Cinnamon,I recommend installing GNOME 3. This may not help, but after I installed GNOME 3 Cinnamon worked.(I also had the same problem.)

sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update
sudo apt-get install gnome-shell

Then install Cinnamon again.

share|improve this answer

This PPA does not contain the latest version of Cinnamon. It is relatively old given the rapid pace of development and the maintainer has not (as yet) updated this PPA.

As such, I would recommend you purge the PPA and install the latest version as per this Q&A:

how to

Install ppa-purge

sudo apt-get install ppa-purge

The purge the ppa:

sudo apt-get -f install
sudo ppa-purge ppa:ppa:merlwiz79/cinnamon-ppa
sudo apt-get update
share|improve this answer

This is an odd problem. Usually, apt-get automatically installs all of the necessary dependencies for a package. You should run sudo apt-get install cinnamon cinnamon-settings cinnamon-theme libmuffin0 gir1.2-muffin-3.0 libcogl5 to install Cinnamon.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.