Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A few days ago I started having this problem.

When I tried to connect to any WiFi Connection it would stay connecting forever, and after a minute or so it would ask me for the password again.

The strange thing is that this happened out of nowhere, I did not install any new drivers or anything like that. After this happened I decided to uninstall ubuntu and install it again ("inside windows") but the problem is still there. Any suggestions would be greatly appreciated.

0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hp-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: eth0
       version: 06
       serial: 2c:27:d7:aa:e4:7d
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:50 ioport:4000(size=256) memory:c0404000-c0404fff memory:c0400000-c0403fff
  *-network
       description: Wireless interface
       product: Centrino Wireless-N 1000
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:0d:00.0
       logical name: wlan0
       version: 00
       serial: 00:1e:64:09:9c:58
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.2.0-23-generic-pae firmware=39.31.5.1 build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:52 memory:c4500000-c4501fff
  *-network
       description: Ethernet interface
       physical id: 1
       bus info: usb@2:1.2
       logical name: eth1
       serial: ee:85:2f:7d:80:96
       capabilities: ethernet physical
       configuration: broadcast=yes driver=ipheth ip=172.20.10.2 link=yes multicast=yes
share|improve this question
    
Could there be any problem with my wireless driver? My computer worked just fine until it suddenly stopped working, and now even if I try reinstalling Ubuntu it won't work (tried with 12.04 and 11.10) –  waclock Jun 23 '12 at 23:15
    
I've had similar problems in the past (not with N). Not sure exactly how I fixed it, but it involved connecting to the router/gateway with an Ethernet cable so I could get to 192.168.1.1 which is the router configuration. One thing that probably shouldn't have made any difference, but seemed to help, was retrieving the password from the router in hex and using that to signon to wireless. –  Joe Jun 27 '12 at 21:23
    
Hmmm, I'll try that tonight. I do have access connecting directly to the router. –  waclock Jun 28 '12 at 21:39
    
Can I Bump this somehow? –  waclock Jul 8 '12 at 0:57
    
You might want to try posting on linuxquestions.org/questions/linux-laptop-and-netbook-25 assuming your computer is a notebook. –  Joe Jul 9 '12 at 16:41
show 4 more comments

1 Answer

try to tune the buffer size

sudo echo 83886080 > /proc/sys/net/core/wmem_max

share|improve this answer
    
Could you please make your answer more complete and give some more information about this fix? –  rosch Oct 18 '12 at 13:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.