Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try to update 12.04, I get the "Package Operation Failed" message. I haven't been able to update my system. In the "Details" section it says:

installArchives() failed:  
Extracting templates from packages: 30%% Extracting templates from packages: 61%% 
Extracting templates from packages: 91%% Extracting templates from packages: 100%% 
Preconfiguring packages ...

Extracting templates from packages: 30%% 
Extracting templates from packages: 61%% 
Extracting templates from packages: 91%% 
Extracting templates from packages: 100%% 
Preconfiguring packages ...

Extracting templates from packages: 30%% 
Extracting templates from packages: 61%% 
Extracting templates from packages: 91%% 
Extracting templates from packages: 100%% 
Preconfiguring packages ...

Extracting templates from packages: 30%% 
Extracting templates from packages: 61%% 
Extracting templates from packages: 91%% 
Extracting templates from packages: 100%% 
Preconfiguring packages ... 

dpkg: error: parsing file '/var/lib/dpkg/available' near line 42150 package 'x11-apps':  blank line in value of field 'Description' Error in function:
share|improve this question

2 Answers 2

See the following page for the answer: How do I fix dpkg errors after a failed upgrade?

You just need to know which is the file that has the bug, in my case it was 'available' and it was just after line 42150.

share|improve this answer
sudo rm -r /var/lib/dpkg/info/pppconfig*
sudo dpkg --remove --force-remove-reinstreq pppconfig
sudo apt-get clean
sudo apt-get update
sudo apt-get install pppconfig

Source

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.