Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install 64 bit ubuntu desktop to the machine I stated above. When I try to do so by CD, the screen freezes, and when I try to do so using USB drive, the screen freezes again just after the line : [Firmware Bug] ACPI(PEGP) defines _DOD but not _DOS

Is there anyway I can overcome this problem ?

ps: Installation procedure starts and works fine on other machines using the same CD and USB drive

share|improve this question

2 Answers 2

For everyone else getting this problem. Do not use acpi=off you better use acpi=noirq instead.

share|improve this answer

When booting the CD/USB you see a purple screen with a keyboard icon in the bottom center. When this screen appear just press any key (like the arrow keys) from the keyboard once in order to make appear all the options.

Then press F6 and selection nomodeset. And try to install it like that.

share|improve this answer
    
don't do acpi=off. It could be destructive. use nomodeset. use acpi=off as last resort. @aliasbosy, please edit it. read here ubuntuforums.org/showthread.php?t=1613132 –  Web-E Jun 23 '12 at 17:33
    
Oops :S My fault, you are totally right :S I will edit then ! –  aliasbody Jun 23 '12 at 17:34
    
Please go through the link , if nomodeset doesn't work. Just use instruction in the link , look for option acpi_osi –  Web-E Jun 23 '12 at 17:37
    
I have tried everyone of them and only acpi=off works for me however, it is mentioned that this option might be risky, do you have any other suggestions for me ? –  Pumpkin Jun 23 '12 at 19:40
    
I don't know if the bug has been fixed in the newest versions of the kernel tho... But just in case, try to install with the "acpi=off" option since it works, and then after the instalation, try to start ubuntu normally, if it doesn't work, try with nomodeset, if it doesn't work, try with acpi_osi, if it still doesn't work, then try with acpi=off and fully update ubuntu (it will install the new kernel), then restart and boot normally and see if it worked. –  aliasbody Jun 23 '12 at 20:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.