Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04 and compiled and installed GTK 3.4 to go through some GTK developer tutorials.

Installing this version of GTK has caused problems with Unity.

All system dialogs and top bar now have a different (older) look, and when I try to launch Nautilus I get the following message:

Gtk-Message: Failed to load module "canberra-gtk-module" 
Initializing nautilus-open-terminal extension 
Initializing nautilus-dropbox 1.4.0 
Initializing nautilus-gdu extension 
nautilus: symbol lookup error: nautilus: undefined symbol: ubuntu_menu_proxy_get

I have run make uninstall on the newer version of GTK and reinstalled just about every package I can think of, but I am still having the same problem.

How can I repair the default Ubuntu GTK libraries?

EDIT

Also, I noticed that my desktop icons are gone (launcher works), and I can't interact with the desktop. I can't drag any shortcuts to it, etc.

share|improve this question
    
can i get which site that you follow the tutorial. Thanks. –  penreturn Jun 23 '12 at 16:37
    
@penreturn - developer.gnome.org/gnome-devel-demos/unstable and gtk.org –  Dana Holt Jun 23 '12 at 17:00
add comment

1 Answer

Long shot guess: Within dconf-editor (install it with sudo apt-get install dconf-editor), navigate to:

org/gnome/settings-daemon/plugins/xsettings/

Is it active?...Its a harmless(?) thing to try.

There is also dconf to do it with a cli command, (run dconf help) but i like to check first how it is actually set.

Long story (could be helpful?):Same boat, not sure same storm:

Tried even with gtk-change theme, gnome-tweak, Ubuntu Tweak... to no avail. It affected all GNOME, including shell, Unity and even Cairo-Dock sessions.... No font settings size or hinting would show any difference...(I think it was after fiddling with gnome-shell and/or accessibility zoom settings...not really sure)

xdiagnose informed me that Raleigh was the "old-look" (GTK...2?) theme i could not get rid of, but gave me the clue. Searched for it in the filesystem / and digging thru the folders i found a text that explained it was the last resort theme in case nothing was defined. (/usr/share/themes/Raleigh/gtk-2.0/gtkrc).

So (kind of a hunch) i went to dconf-editor to org/gnome/settings-daemon/plugins/ and checking thru the keys there (i turned them all on as a desperate measure....i don't really recommend doing it so blindly...it worked for me thou...) i "stumbled" upon the -last- one: "xsettings" and found it was NOT activated. Activating THAT did the trick.

share|improve this answer
    
Hi, thanks for the idea. Sadly xsettings was already activated on my system. –  Dana Holt Aug 28 '12 at 12:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.