Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Problem description
The compiz grid feature just stopped working a couple of days ago: for instance I used to be able to move a terminal window to the top left corner by pressing <ctrl><alt>KP7 but now the number 7 appears in the terminal and the window doesn't move.

-compiz grid is enabled and I have restored its configuration to the default values
-my numpad is working properly (i.e. if it's locked I get the numbers, if not I get home, ins, del... as expected).
-I looked into the Keyboard and Keyboard layout settings but I don't see any option I could tweak to fix the problem.

What do I need to do in order to restore the compiz grid feature?

share|improve this question
up vote 0 down vote accepted

Turns out issue was caused by a combination of factors:

  • Compiz (at least its grid component) requires Ubuntu 3D desktop (if you run $ echo $DESKTOP_SESSION inside a terminal and get ubuntu 2d it means you're not running the 3d desktop).

  • I couldn't run the 3d desktop because my Nvidia card was not being properly supported with the default drivers (which I solved by installing the BumbleBee drivers).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.