Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Or, alternatively, how can I check that some WiFi chip supports WPA-encrypted hotspot creation? Is it hardware-dependent? Is anyone able to create WPA-encrypted hotspot?

Update: See the discussion at

Related bug reports:

share|improve this question
"how can I check that some WiFi chip supports WPA" with your model device. "Is it hardware-dependent?" There is many router that doesn't but there is an algorithmic (TKIP) that solve that compatibility problem. – Lucio Jun 23 '12 at 0:02
Notice: I'm talking about Ubuntu in a hotspot mode, not about routers – int_ua Jun 23 '12 at 2:10
As an aside, this may be a kernel incompatiblity problem, as the GNOME bug tracker here suggests that newer kernels do not work with WPA / WPA2 on Ad-Hoc networks. – Thomas Ward Jun 25 '12 at 13:23

Both the SIOCSIWENCODEEXT and SIOCSIWGENIE errors are usually intimately associated with WPA/wpa_supplicant failure.

Have you tried recompiling the latest RT2790 driver with *wpa_supplicant* support enabled -- by default it's NOT!. Also, note that it only supports WPA PSK for adhoc (see line 280 of README_STA below)

  1. Get the latest driver, download, extract, cd to the directory.
  2. Inside os/linux/, find lines 10-14, which read:

    # Support Wpa_Supplicant
    # Support Native WpaSupplicant for Network Maganger
  3. Change the n at the end of both those lines to y.

  4. make and sudo make install the driver (you'll need kernel headers, etc - comment if you need more info on the process).

Reboot, and see if things are any different (errors, etc.) with WPA adhoc.

If not:

  1. Following the README_STA file in the extracted directory, copy it cp RT2860STA.dat /etc/Wireless/RT2860STA/RT2860STA.dat
  2. Open that file, and change:

    • NetworkType=Adhoc
    • Authmode=WPANONE : important only this (WPA PSK) is supported for adhoc
    • Try EncrypType=NONE (and even TKIP and AES, because README does not say which is supported for adhoc)
    • Set WPAPSK to the key -- ***wpa_supplicant* may not be fully supported in adhoc*
  3. Unload/load the the module to make it take effect: rmmod and modprobe, respectively.

  4. See the README_STA file for more parameters and details, and try experimenting. Comment if you need more help.

share|improve this answer
Unfortunately, I'm out of town with a very limited GPRS traffic, can't check the solution right now. Also, I was asking a generic question, I don't really like your edits since all notebooks with 12.04 I've met wasn't being able to create WPA-encrypted hotspot. And that's a big issue that should not be split into hardware-specific discussions. – int_ua Jul 2 '12 at 20:00
@int_ua: I understand, I reverted the edits. – izx Jul 2 '12 at 20:04

To start a WPA adhoc network, create wpa-adhoc.conf:

ap_scan=2 network={
        ssid="test adhoc"
        psk="passphrase" }

And start it by running:

wpa_supplicant -cwpa-adhoc.conf -iwlan0 -Dwext

Useful resources:

  • Find the chipset of your wireless and check if it's supported here.

Alternatively, in case that WPA encryption is not supported you could establish a VPN between hosts, either using OpenVPN or even SSH.


  1. Creating an ad hoc network.

  2. Wireless Cards Supported

share|improve this answer
Why NONE? Can we use TKIP for example? Trying this. – int_ua Jun 25 '12 at 12:22
And it creates open adhoc network, no encryption at all. – int_ua Jun 25 '12 at 12:34
@int_ua : Just to clarify, have you tried this and you resulted with an open adhoc network? – pl1nk Jun 25 '12 at 12:42
Yes, I've copied the config adding only new lines where they should be and changing the password and executed the wpa_supplicant command with sudo. It showed a couple of ioctl[SIOCSIWENCODEEXT]: Invalid argument and the network is showed as non-encrypted on Nokia N900. The output: – int_ua Jun 25 '12 at 12:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.