Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

so I was trying to add global menu support for Eclipse from this short fix from here and it worked. I tried adding another application into that by typing the application in there as well and it didn't work, so I removed it.

Since then, I can't run a lot of applications after a restart. They all say Segmentation fault (core dump).

Here is a core dump file from one application Synergy: https://gist.github.com/2974295

This only seems to be happening to my user account though. Other accounts and root can start up fine..

I would really appreciate the help!

share|improve this question

closed as too localized by Rafał Cieślak, hbdgaf, Jorge Castro, John S Gruber, jokerdino Aug 21 '12 at 7:40

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 2 down vote accepted

Try re-installing the appmenu-gtk package:

sudo apt-get install --reinstall appmenu-gtk

I hope this works.

share|improve this answer
    
Worked great! I didn't know the package it belonged to before. :) –  jonalmeida Jun 22 '12 at 19:04
1  
You can find out which package a file belongs to using dpkg -S /path/to/file. If the file isn't installed (e.g. you know you need a certain development header file or a library), you can install the utility apt-file. –  Michael Wild Jun 24 '12 at 19:28
    
Thanks again :) –  jonalmeida Jun 26 '12 at 21:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.