Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to enable compiz on my laptop via Desktop Effects but it does not allow it. I modified the xorg.conf file as on the compiz wiki but still no luck.

So can someone just tell me how to enable compiz desktop on an Intel i5 based system. This is an Arrandale processor so its got the graphics bit on the processor itself. My system also has a discrete graphics card (Nvidia GT330M - yup its those hybrid graphics combos n- not Optimus). As far as i know the nvidia gpu is not being used since the intel one is enabled and there is no bios route to disable it. The laptop is a Dell Vostro 3700 with bios version A10

I did lotsa google searches about intel compiz, etc but not a single conclusive guide as to how to enable it. so my guess is it should work out of the box. but it doesn't.

glxinfo

gives me:

name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
3 GLXFBConfigs:
   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Segmentation fault

lsbusb gives me:

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18) 01:00.0 VGA compatible controller [0300]: nVidia Corporation GT216 [GeForce GT 330M] [10de:0a29] (rev a2)

share|improve this question
3  
"GLX" missing means you are not able to use OpenGL with current drivers. As much I googled, I saw people having a lot of problems, so if you want eye candy, I recommend setting Nvidia as your default output. –  danizmax Nov 30 '10 at 10:32
    
What's the model name of your notebook? –  htorque Nov 30 '10 at 12:30
    
Look at this question to find what kind of information we need to help you and then just add it to your question: askubuntu.com/questions/14008/… –  Jorge Castro Nov 30 '10 at 15:56
    
@htorque It is a Dell Vostro 3700 with bios version A10. –  Eshwar Nov 30 '10 at 18:52
    
@Jorge Castro apologies for the incomplete info, here is output from lspci, 00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18) 01:00.0 VGA compatible controller [0300]: nVidia Corporation GT216 [GeForce GT 330M] [10de:0a29] (rev a2) i am confused on how to attach a log to this? –  Eshwar Nov 30 '10 at 18:53

3 Answers 3

Like peopple pointed you might be running a nvidia card. Did you try to install the nvidia proprietary driver?

share|improve this answer
    
yes i did. somehow i cannot access the settings page since the nvidia drivers seem to require xorg.conf be set up. now as soon as that is set, the laptop cannot complete the boot process. i could startup by modifying the xorg.conf to include both graphics adapters but still compiz didnt work. –  Eshwar Dec 7 '10 at 8:26
    
did you install the nvidia driver from ubuntu packages or manually? –  Marcos Roriz Junior Dec 7 '10 at 15:08
    
nvidia-current from PPA :) –  Eshwar Jan 12 '11 at 9:34
up vote 1 down vote accepted

I managed to get compiz to work. i uninstalled nvidia's proprietary driver (nvidia-current). now with nouveau, glxinfo gives decent output and says direct rendering is enabled (turns out its talking about the intel chip). then i go to desktop effects, and when i select extra, it says install nvidia proprietary drivers, i click cancel, the screen blinks but compiz is now enabled

Ubuntuforums solution

share|improve this answer

Try to install bumblebee to have both the Intel and Nvidia cards working simultaneously: https://launchpad.net/~hybrid-graphics-linux

sudo apt-get install git
# type password
git clone http://github.com/MrMEEE/bumblebee.git
cd bumblebee/
sudo ./install.sh
optirun glxgears
# check the speed and compare to running:
glxgears
# If you have google-chrome installed, you can try it with/without optirun and report the FPS values on the mailing list:
optirun google-chrome http://webglsamples.googlecode.com/hg/aquarium/aquarium.html
share|improve this answer
    
Thanks! asked in the other question if vdpau is supported :) –  Eshwar Jul 26 '11 at 16:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.