Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm an Ubuntu 12.04 user, using Gnome Classic (with no effects). I don't know what I did, but lately instead of the keyboard layout with the locale (for example, IT, UK and so on) a strange "no access" symbol appears. See the linked image.

ow can I restore the default keyboard icon and the language indicator?

enter image description here

Issuing

locale -a

in a terminal i get the following output:

locale -a
C
C.UTF-8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8 
en_ZM
en_ZM.utf8
en_ZW.utf8
POSIX
share|improve this question
    
please share the output of locale -a. –  Samik Jun 22 '12 at 16:20
    
Thanks @Samik I edited the question so to contain the output. –  lucacerone Jun 22 '12 at 18:24
    
Can you go to gnome-control-center > Keyboard Layout > Add(+)> select layout? –  Samik Jun 22 '12 at 18:37
    
Hi @Samik, yes I can –  lucacerone Jun 22 '12 at 18:42
    
Sorry I misunderstood your question , thought your keyboard-indicator is disabled. –  Samik Jun 22 '12 at 19:18

1 Answer 1

up vote 3 down vote accepted

Usually that symbol means a missing pixmap/image. I think either the keyboard icon image or the country-flags icons are missing. You can install dconf-tool with sudo apt-get install dconf-tool, open the dconf-editor then go to org>gnome>libgnomekbd>indicator and uncheck the show-flags option if it's checked. Log-out and log-in back again to see if the keyboard icon appears there.

share|improve this answer
    
Hi @Samik, I'll try this solution as soon as I'm in front to the computer with this issue and let you know if it worked –  lucacerone Jun 27 '12 at 8:44
    
Hi @Samik, I have tried your solution. It worked in the sense that now instead of the ugly "forbidden" signal a fancy keyboard icon is displayed. What I can't manage to see though is the layout used. I have an UK keyboard, but since I'm Italian I switch frequently between the UK Standard (when I program) and the UK Extended (when I have to write in Italian). On my laptop when I switch keyboard I have "en" or "en2" displayed closed to the keyboard that tells me which layout I'm using. Can I restore that behaviour as well? Thanks a lot for the help! –  lucacerone Jun 27 '12 at 10:11
    
@LucaCerone The behaviour you want seems to be changed in new releases, the indiactor either use the country flags or the keyboard icon. But here you can download country flags which are actually images showing two letter country codes. Extract them in /home/<user>/.icons/flags or /usr/share/pixmaps and re-enable the show-flags using dconf-editor. –  Samik Jun 27 '12 at 11:36
    
that package doesn't include the flags for English Uk.. I could create it just copying the file en.svg and renaming it into gb.svg. Doing that the indicator for the English Uk layout is shown correctly. I can't find the combination for the English UK international layout though. –  lucacerone Jun 27 '12 at 14:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.