Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My ubuntu is 10.04. The top and bottom gnome-panel suddenly become transparent. However mouse click the position of menu, the Application menu could be shown.

It could be fixed by restarting my x-seesion(logout then login). But it would happen again in several hours.

Does anyone have idea to fix it permanently?

alt text

Update:

The compiz is off. However the panel will show after changing the 'Visual Effects' option from 'none' to 'normal'.

Update2: Changing theme also make the panel visible again. But it would be invisible again in minutes.

share|improve this question
1  
Right click your panel and select None (Use System Theme) Also are you using compiz? –  karthick87 Nov 30 '10 at 7:36
    
@karthick87, I don't set background for that panel. And the compiz is off now. The none option of 'visual effects' is checked. I tried to set it to normal, the panel is shown again! I changed it to none to see what it will happen. Thanks for giving me a hint. –  Kane Nov 30 '10 at 7:44
    
Sounds like a bug, perhaps in the video driver. What sort of video card do you have? –  Marius Gedminas Nov 30 '10 at 12:14
    
@Marius, I don't think so. I'm using ubuntu 10.04 since it's released. This issue happens in recent days. The pc is Dell Optiplex 760. –  Kane Nov 30 '10 at 14:09

2 Answers 2

up vote 0 down vote accepted

Try this :

gconftool-2 --type bool --set /apps/metacity/general/compositing_manager "false"

Metacity has a compositing manager that doesn't work very well, it shouldn't be activated by default but your problem make me think that it is activated.

After that, restart and see if the problem still occur.

share|improve this answer
    
It looks like work. But I'm not sure whether it's resolved due to removing all packages have word 'compiz'. –  Kane Dec 2 '10 at 7:05

To restore gnome panel to default settings.Type the following in terminal

gconftool-2 --recursive-unset /apps/panel && killall gnome-panel &
share|improve this answer
    
it doesn't work. Even I have remove 'compiz' package, the problem would be reproduced again. –  Kane Nov 30 '10 at 10:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.