Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Sony Vaio E Series VPCEH25EN laptop. I installed ubuntu 12.04 64 bit version and I couldn't change my brightness level.

Always it is showing max brightness,

I tried to change by using echo 0 | sudo tee /sys/class/backlight/acpi_video0/brightness command.

When I run the above cmd it showing output as 0 but there is no change in brightness level. please help out how to change brightness levels.

share|improve this question
    
Please do not post your question as an answer to similar questions! –  izx Jun 22 '12 at 10:28
    
take a look at this post. I have a NVIDIA chip to and had to edit my xorg configuration to get Brightness Control askubuntu.com/questions/76081/… –  quidage Jun 28 '13 at 10:35

2 Answers 2

Your system has nvida chips. So please install driver from Addtional Drivers (press Super / Win, and search for it). Reboot and see if it solves the problem.

If above not working try following (but don't uninstall the driver)

execute sudo gedit /etc/default/grub

Change this line

GRUB_CMLINE_LINUX_DEFAULT="quiet splash"

to something like below

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Execute sudo update-grub and reboot . See if brightness keys are working.

It is still possible ubuntu won't remember your brightness settings. So you have to change brightness each time.

Please let us know the result as many sony users are facing this problem.


Update: This is for setting brightness manually.

Try following for path shown by ls /sys/class/backlight/*/brightness and replace accordingly.

Get the maximum brightness:

cat /sys/class/backlight/intel_backlight/max_brightness

Try a lower value to set the brightness, say output is 2048 so I will try with half of it

echo 1024| sudo tee /sys/class/backlight/intel_backlight/brightness

If this works, make this happen in each login automatically by doing the following

sudo gedit /etc/rc.local

Enter this line just before exit 0. It should look like

echo YOUR_VALUE_HERE > /sys/class/backlight/intel_backlight/brightness
exit 0

Also you can try with xdotool Install xdotool

share|improve this answer
    
i tried both but still the same problem.no change at all –  yashwanth Jun 22 '12 at 11:24
    
i tried that...first i tried changing the value lik the way u said by using echo | but there is no change at all...the display brightness is same at the max level –  yashwanth Jun 22 '12 at 13:12
    
did you installed the driver? see this user is reporting it worked correctly. What is o/p of ls /sys/class/backlight/*/brightness ? –  Web-E Jun 22 '12 at 13:44
    
when it is in max_brightness range its displaying as 15..even though i change the value its changing to 8,9 etc but the screen brightness is still at high state... –  yashwanth Jun 24 '12 at 15:00

This link helps me to solve this issue: http://askubuntu.com/a/266618/186926

Problem solved just by editing /etc/X11/xorg.conf file. If this file is not there in your system, then create it and copy paste its content as mentioned in above link.

Cheers!

Jasleen

share|improve this answer
    
Welcome to Ask Ubuntu! Here at Ask Ubuntu, we help moderate the site by flagging questions as duplicates to others. Invest some time in the site and you will gain sufficient privileges to flag posts. –  Alaa Ali Aug 24 '13 at 16:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.