Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought the new ultrabook Sony VAIO SVT1311. Many things work but brightness control doesn't. I see the splash bubble (that reacts to Fn+F5 and Fn+F6) but the brightness doesn't change. It stays permanent at 100% and I can't do anything with it. The graphics card is integrated Intel HD3000.

share|improve this question
    
what is output of ls /sys/class/backlight/*/brightness –  Web-E Jun 22 '12 at 9:55
    
/sys/class/backlight/acpi_video0/brightness /sys/class/backlight/intel_backlight/brightness –  Sergey Kozlov Jun 22 '12 at 10:08
    
possible duplicate of Brightness doesn't change on Sony laptop –  con-f-use Nov 3 '12 at 21:54

2 Answers 2

up vote 0 down vote accepted

To get working brightness key. try following

execute sudo gedit /etc/default/grub

Change this line

GRUB_CMLINE_LINUX_DEFAULT="quiet splash"

to something like below

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Execute sudo update-grub and reboot . See if brightness keys are working.

It is still possible ubuntu won't remember your brightness settings. So you have to change brightness each time.

Please let us know the result as many sony users are facing this problem.


Update: This is for setting brightness manually.

Try following for both path shown by ls /sys/class/backlight/*/brightness and replace accordingly. Most probably the intel one should work.

Get the maximum brightness:

cat /sys/class/backlight/intel_backlight/max_brightness

Try a lower value to set the brightness, say output is 2048 so I will try with half of it

echo 1024| sudo tee /sys/class/backlight/intel_backlight/brightness

If this works, make this happen in each login automatically by doing the following

sudo gedit /etc/rc.local

Enter this line just before exit 0. It should look like

echo YOUR_VALUE_HERE > /sys/class/backlight/intel_backlight/brightness
exit 0

I have another question. Does your system has hybrid graphics card? whats the output of lspci | grep vga ?

Also you can try with xdotool Install xdotool

share|improve this answer
    
I changed grub settings: now the bubble can switch between 90% and 100%, but anyway the brightness remains maximum. This notebook hasn't light sensor so the way under the link is not for me. –  Sergey Kozlov Jun 22 '12 at 11:35
    
I have updated. Please try them. –  Web-E Jun 22 '12 at 12:16
    
Yes, it works! Only with intel (max - 4882). With /sys/class/backlight/sony/brightness (max - 7) it doesn't. If I set value to rc.local, this will be for all session and coldn't be changed during work. –  Sergey Kozlov Jun 22 '12 at 12:38
    
I have only HD3000 without another graphics card –  Sergey Kozlov Jun 22 '12 at 12:42
    
yea.. update rc.local. And accept this answer by clicking the tick button on upper left of my answer –  Web-E Jun 22 '12 at 12:46

adding acpi_backlight=vendor to the grub command line like suggested above did not help in my case. My workaround was to use the intel_backlight command from command line.

example:

# set the brightness down to 20%:
intel_backlight 20
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.