Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Sony VPCW218AG netbook that I've dual-booted with Ubuntu 10.10. Unlike the preinstalled Windows 7, Ubuntu will not reboot on this computer. Rebooting from Gnome, using the reboot command and SysRq+REISUB all don't work; they end hanging with a blank screen.

I have read that Atom netbooks don't have a keyboard controller and therefore the default reboot method, kbd, won't work. I have actually tried all ten reboot= parameters listed here; none of them work.

I have also tried disabling ACPI with noacpi acpi=off for each one; that didn't help either.

Are there any other things I can try to fix the rebooting problem?

share|improve this question

closed as off topic by jrg May 22 '12 at 18:58

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Why don't you complete your bug report on launchpad with the requested datas? bugs.launchpad.net/ubuntu bug/668274 –  Nyamiou The Galeanthrope Nov 30 '10 at 16:41
    
I'm attaching the files right now. –  Delan Azabani Dec 1 '10 at 4:25
    
All done. Apport tells me to try a mainline/git kernel so I'll try that now. –  Delan Azabani Dec 1 '10 at 4:36
add comment

3 Answers 3

Interesting bug. I would try using Alt-SysRq-T to see what tasks seem to be running, then file a bug based on that. It would also be interesting to know whether Alt-SysRq-B reboots it or not.

share|improve this answer
add comment
up vote 1 down vote accepted

After various experiments, I've reached a solution for this laptop.

I've installed gentoo, compiling a kernel with CONFIG_SONY_LAPTOP and CONFIG_SONYPI_COMPAT enabled. With that driver included, setting reboot=bios on the kernel command line worked (of course, as reboot=bios depends on x86-32, it probably won't work on x86-64 and another solution will be needed). Even though I found this solution in gentoo, it would almost certainly work in Ubuntu too.

After more experimenting, it turns out that the only thing I needed was reboot=bios. However, that doesn't work on x86-64, so I'm stuck with x86-32 (that doesn't matter much though; this netbook only has 1GB of RAM).

share|improve this answer
add comment

did you also try specifying multiple params? Avoid using the kbd method if the keyboard controller dosen't exists(i actually never encountered this situation, but from old experiences with DOS, accessing invalid controllers may lead to system hangup)..

Are you sure that when the system hangs all other apps are closed? Did you try looking into lastlog?

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.