Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got this error while trying to install ubuntu 10.10 from a bootable USB stick on to asus x64j series laptop. After getting this error the installation fails to start.

I have used the same USB stick on some other laptops and the installation started as usual. Any help will be appreciated.

share|improve this question
I got the same problem when installing Ubuntu 10.10 from USB sick onto HP EliteBok 8740w. Tried two different USB sticks, with no success so far. Cannot install, neither boot Ubuntu from the stick. It all ends up with this error message. Hint is needed. –  Alex Savin Jan 6 '11 at 0:16
I am having the exact same issue on a Dell Studio. This evening, I installed the 10.10-desktop-I386 on a USB stick. I saved the ISO to my local machine prior to installing the USB Universal Installer on the flash drive. The install referenced the local ISO and I chose the option to format the flash drive as FAT32 to confirm correct formatting. After the first round of headaches, I deleted everything from the flash drive and started over. No change. The Ubuntu screen will load but then cut to console and display "Unable to find a medium with a live file system." Any Suggestions? –  Michael Jan 6 '11 at 4:14
Hi everybody i got the same error while trying to install 10.10 on my notebook Vaio X from USB-drive. I didn't have any problem with the 10.04. I used StartUp Disk Creator on USB 4.0 giga memory. No clue.... –  user10078 Feb 2 '11 at 19:02
I'm having the same exact issue (except my installation is i386 and my machine is Vaio P VGN-P610). I've tried every possible thing: > Bios: [enable boot external] > > Boot order: [external] [hard drive] [network boot] > > Tried 2 different USB drives > > Tried 2 different external CD drives > > Tried 6 different downloads of both the desktop and netbook remix. > > All downloads were checked with MD5SUM. > > Ubuntu Desktop 9.10 installs properly in every version and from every source. Getting reaaaally frustrated. –  user10982 Feb 17 '11 at 1:32

8 Answers 8

up vote 13 down vote accepted

For me changing from USB 3.0 socket to 2.0 helped. I'm using 10.04 Ubuntu on Asus 1015PEM.

share|improve this answer
Worked! I read through some answers and i tried on of them and worked. put the usb into usb2.0 socket. I was using the usb3.0 socket and it was giving me trouble. long live ubuntu community. without these many people sharing knowledge on, it is not possible to overcome such issue. –  user11509 Feb 26 '11 at 13:05
How come, but it's running :) –  mithy Sep 26 '13 at 18:48
On an ASUC desktop PC, I tried to boot Kali Linux live from USB stick (UNetbootin). To fix the error "unable to find a medium containing a live file system” (I first got "can't open /sys/block/*/removable"), I had to switch "Installer OS select" from "Windows" to "Others" in the BIOS (2008 version). –  baptx Apr 24 at 13:30

ya you should first make the default booting device to usb drive. i think you have chosen unetbootin for burning which is not useful i myself faced same problem. use multi boot iso which is good...

share|improve this answer
I am not burning anything since I use an USB stick –  dds Nov 30 '10 at 19:39

I recieved the same error, “unable to find a medium containing a live file system”, when installing from a SATA DVD drive. Installing using USB 2.0 stick worked though.

share|improve this answer

Assuming that the data on your stick are o.k. (did you try to boot with this very stick on another machine?), check that BIOS is set for booting from "USB-HDD" or something like that as first boot device.

Edit: I can see this was done. Maybe other BIOS settings for USB or HD access need to be corrected. Your error indicates mounting problems.

From here we can only guess. Try switching from IDE to AHCI, deactivate BIOS support for any non-existent devices, check your BIOS is up to date etc. I do believe it is some BIOS issue we have here.

share|improve this answer
c'mooon... it should be already booted to able to display any error about live file system. otherwise it would continue to boot from HDD and if HDD doesnt have a OS it would say some error other than live file system –  dds Nov 30 '10 at 19:38

You need change your bios from IDE to ACHI.

share|improve this answer
It should have been a solution for me, but Acer Aspire All-in-One BIOS is short of configuration options. I solved the issue by setting "USB Emulation" to "HDD". –  Dmitry Fedorkov Jun 22 '13 at 2:58

The content of the USB may have been corrupted. I had this about some months ago. If you have a second PC with Ubuntu try to create a new bootable Live USB from System --> Administration --> StartUp Disk Creator.

share|improve this answer
whats wrong with you guys? I have already said that I tried the USB stick with another computer and it works! dont you read the whole question? –  dds Nov 30 '10 at 19:34

Greetings. I just solved this. Packard Bell TK85. My boot sequence was USB, CD, HD. I changed it to USB, HD, CD and it worked.

share|improve this answer

I second Funbot's answer. Initially when I got the 'unable to find a medium containing a live file system' error I was booting from the furthest forward usb port on the right hand side.

I switched to the usb port on the left hand side and then it worked fine.

(Ubuntu Netbook edition 10.10 on ASUS eee PC 1015 PEM)

share|improve this answer

protected by Oli Feb 26 '11 at 18:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.