Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Error message:

(initramfs) unable to find a live medium containing a live file system

I got this error while trying to install Ubuntu 10.10 from a bootable USB stick on to Asus X64J series laptop. After getting this error the installation fails to start.

I have used the same USB stick on some other laptops and the installation started as usual. Any help will be appreciated.

share|improve this question

9 Answers 9

up vote 16 down vote accepted

For me changing from USB 3.0 socket to 2.0 helped. I'm using 10.04 Ubuntu on Asus 1015PEM.

share|improve this answer

I recieved the same error, “unable to find a medium containing a live file system”, when installing from a SATA DVD drive. Installing using USB 2.0 stick worked though.

share|improve this answer

Here is what I found looking around for this error message:

Data integrity

Check that the hash of the ISO you downloaded matches the official one. Also try different USB sticks or DVD burners, there may be data corruption on the stick or wear on the drive mechanics you want to rule out.


Hardware issues

To rule out hardware issues you can try a different computer, if available. Remember that you can usually install Ubuntu by installing the target harddrive in another computer and complete the installation there, which may be the quickest workaround in such a situation.

Cause analysis and general advice

The cause of the issue seems to be that the USB or SATA device isn't available or detection is too slow at the time the kernel takes over during the boot process, so that it can't find the image of the live OS to load. Similar to the recommendation in the data integrity section above, try burning optical installation media when you are unable to boot from USB and vice versa. If that's not possible because your computer only has USB 3.0 ports and no internal optical drive, try booting from an integrated SD card reader. Also look out for available firmware updates for your computer that may fix the issue. If you are trying to install from an ISO of an older release, then please try the latest ISO.

As a last resort you can try to use the minimal ISO, which doesn't seem to load another filesystem except initrd but requires a working Internet connection for installation. I would recommend this for Intel Macs from Apple that have this issue.

Hardware issues on laptops and desktops

There seem to be issues on laptops from Dell, Lenovo, Toshiba, Sony and may be other manufacturers. Non-custom built desktops may also be affected and as far as I am aware this is specific to modern AMD processors.

Try changing the firmware settings (BIOS/UEFI) for SATA (set to AHCI mode) when using optical media or use another (non 3.0) USB port when using USB, this seems to work in most cases.

Hardware issues on Gigabyte mainboards

There apparently was or still is an issue on some Gigabyte mainboards with the IOMMU on AMD platforms (Intel calls this VT-d).

I found the following post on the forums (1, 2):

Turns out the IOMMU needs to be enabled in the BIOS. This problems seems to be exclusive to Gigabyte boards.

As well as this answer here on AU:

Gigabyte UEFI boot issues - The partition size of the created USB Installer device needs to be under that of 4GB. Others found UEFI/BIOS update solved issue of 4GB FAT limit.

share|improve this answer

ya you should first make the default booting device to usb drive. i think you have chosen unetbootin for burning which is not useful i myself faced same problem. use multi boot iso which is good...

share|improve this answer
I am not burning anything since I use an USB stick – dds Nov 30 '10 at 19:39

Assuming that the data on your stick are o.k. (did you try to boot with this very stick on another machine?), check that BIOS is set for booting from "USB-HDD" or something like that as first boot device.

Edit: I can see this was done. Maybe other BIOS settings for USB or HD access need to be corrected. Your error indicates mounting problems.

From here we can only guess. Try switching from IDE to AHCI, deactivate BIOS support for any non-existent devices, check your BIOS is up to date etc. I do believe it is some BIOS issue we have here.

share|improve this answer
c'mooon... it should be already booted to able to display any error about live file system. otherwise it would continue to boot from HDD and if HDD doesnt have a OS it would say some error other than live file system – dds Nov 30 '10 at 19:38

You need change your bios from IDE to ACHI.

share|improve this answer
It should have been a solution for me, but Acer Aspire All-in-One BIOS is short of configuration options. I solved the issue by setting "USB Emulation" to "HDD". – Dmitry Fedorkov Jun 22 '13 at 2:58

The content of the USB may have been corrupted. I had this about some months ago. If you have a second PC with Ubuntu try to create a new bootable Live USB from System --> Administration --> StartUp Disk Creator.

share|improve this answer

Greetings. I just solved this. Packard Bell TK85. My boot sequence was USB, CD, HD. I changed it to USB, HD, CD and it worked.

share|improve this answer

I second Funbot's answer. Initially when I got the 'unable to find a medium containing a live file system' error I was booting from the furthest forward usb port on the right hand side.

I switched to the usb port on the left hand side and then it worked fine.

(Ubuntu Netbook edition 10.10 on ASUS eee PC 1015 PEM)

share|improve this answer

protected by Oli Feb 26 '11 at 18:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.