Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem working with the Fn hotkeys on my brand new laptop Asus. I cannot change my volume, screen brightness, keyboard back light and other minor functions. I have tested many possible solutions, but without any sucess. Thank you!

I aprecciate some help!

share|improve this question
1  
+1 on this. Can you please describe what you've already tried? –  noamt Jun 22 '12 at 19:38
1  
What is your Ubuntu release? and is it up-to-date? –  Mitch Jul 4 '12 at 17:44
1  
I have the same problem on my Asus N56VZ. My Ubuntu release is 12.04 and is updated. –  Keppil Jul 4 '12 at 20:19
1  
Diogo, can you post some details about your laptop? –  Paulocoghi Jul 5 '12 at 12:51

4 Answers 4

The first thing I would try is to run xev from the terminal and try pressing the keys in question.

See what KeyPress events it reports. That might point to a solution you can find on your own or you could post them here.

share|improve this answer
3  
I get no KeyPress events from the keys in question. –  Keppil Jul 2 '12 at 17:10
    
I was sure that the fn keys are handled on a lower level, and that these are actually driver related issues. –  noamt Jul 10 '12 at 17:36
    
If they are all multimedia keys, they don't show up in xev. Sorry, forgot about that. –  otus Jul 18 '12 at 12:49

Well, assuming you're using 12.04 LTS, the hot key setting is more included with the default operating system. I has an ASUS eeePC 900 and when I went from Windows XP to Windows 7, I lost functionality of my function keys as you have. My recommendation, is to simply goto: System Settings > Keyboard > Shortcuts (This is a tab located at the top.) and then create a custom short-cut as the computer has listed on the keyboard for the functions you desire. That would seem to be the easiest way, I don't know about keyboard backlight however, that sounds as if it would be managed with an included tool made specifically for the computer, not included with the operating system in question.

share|improve this answer

There is a solution. You can see my answer to a similar question for the same hardware here if it can help you.

share|improve this answer
    
Thanks for the update –  noamt Jul 30 '12 at 13:07

Even simpler, just reinstall the driver from the Asus website or CD. I've had this issue twice now. It's to do with your drivers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.