Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The touch pad is detected as PS/2 Generic Mouse. Installing this driver don't help.

After using it with this: "download that alps-dkms package and install it in /usr/src. from a terminal, navigate to /usr/src/psmouse-alps-0.10/src and then gedit alps.c in alps.c scroll down and copy the /* Dell Vostro 1400 */ line completely. In that line you will have to replace first 3 matches, that is , replace 0x73 , 0x02 , 0x50 with 0x73 , 0x03 , 0x50 . Save the file and return to the terminal. In the terminal type dkms add -m psmouse -v alps-0.10 After this, type dkms build -m psmouse -v alps-0.10 after build is complete, install it with dkms install -m psmouse -v alps-0.10 after it installs it successfully, type rmmod psmouse && modprobe psmouse This will reload your psmouse module. Next, type xinput --list to see whether it loaded successfully or not. If it shows Alps/PS2 Alps GlidePoint in the xinput , than congrats. And i bet it will show as i got it working by this!

the touch pad is recognized as GlidePoint (witch is wrong) and 2 finger scrolling isn't working. (I've forgot to try disable with Fn+F3, and now I installed Ubuntu again so I'll try to fix without any modified files)

How do I enable 2 finger scrolling, and adding the option to enable/disable it with Fn+F3.

I'm using Ubuntu 12.04 64bit.

share|improve this question
    
askubuntu.com/questions/141479/… –  user76985 Jul 14 '12 at 15:03
    
I have dell inspiron n5110 ..Ubuntu 13.04 clean installation ...every thing is working fine –  Qasim May 17 '13 at 16:42

1 Answer 1

You really have two questions that you're asking. One is how to get Ubuntu to correctly recognize your touchpad, and the other is how to add the keybinding.

I don't know how to add the Fn+F3 keybinding to disable the touchpad. Is Fn+F3 a standard multimedia keystroke on your computer designed to disable the touchpad? If so, then you likely will not have to add any extra keybindings to get it to work once Ubuntu recognizes your touchpad correctly. Basically, Ubuntu likely correctly recognizes that you want to disable the touchpad, but, since it thinks that your touchpad is a mouse, sees no touchpads to disable.

One possible solution - upgrade to Ubuntu 14.04. The N5110's are fairly new computers, and as such, some of the hardware isn't necessarily supported by older kernel versions. I'm personally running Ubuntu 14.04 on a Dell Inspiron i3531, and that was initially very frustrating - only kernel version 3.13.0-32 and higher correctly supports the touchpad, and 14.04 came with version 3.13.0-25.

For what it is worth, Ubuntu 14.04 just had its first point release, so it's stable right out of the box with very few bugs. It's also not radically different than 12.04. And if your reason for not upgrading has to do with the commercialization, then install the unity tweak tool - you can get rid of all of the Unity web integration.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.