Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After installing Ubuntu 12.04, I tried to update, but I got the following:

student@student-25:~$ sudo apt-get update && sudo apt-get upgrade
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release i386 (20120423) precise InRelease
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release i386 (20120423) precise/main TranslationIndex
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release i386 (20120423) precise/restricted TranslationIndex
Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release i38Translation-en
Ign precise InRelease                                 
Err precise Release.gpg                               
  Unable to connect to


share|improve this question
Check your internet connection. – izx Jun 21 '12 at 13:06
No internet connection or the server from where you are trying to install the package is unavailable. – Rrjrjtlokrthjji Jun 21 '12 at 13:53
Related:… – Thomas Ward Jun 21 '12 at 17:05

Sometimes there will be a temporary server down too . I am suggesting you to change your server to Best server or update your system after sometime.

To change the server Open `Update Manager > Settings > Ubuntu Software > Download from:` 

that option will hold the server option . choose a best server and try again .

share|improve this answer
I tried the main server but no says "Unable to connect to [IP: 80]" – bell Jun 21 '12 at 15:07
yeah sounds like temp server down .try again after sometime . P.S my ping can read the data from it . – Raja Jun 21 '12 at 15:49
I tried a lot of servers but the error while updating is still there.strangely in this morning sudo apt-get update told me as;" student@student-25:~$ sudo apt-get update sudo: timestamp too far in the future: Jun 23 23:41:22 2012 [sudo] password for student: – bell Jun 22 '12 at 6:28
@bell contact whoever manages your network it seems your internet firewalls are blocking everything. If you're on a home network, try to DMZ your system in your router (temporarily) – Thomas Ward Jun 22 '12 at 12:41

It's usually a good idea to change a server that isn't responding to one in the same general area. For example, I was using (Boston University) and it was giving me some problems. I changed it (in Synaptic) and all was smooth sailing. Bear in mind that you can almost always use the main server if a nearby mirror isn't working.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.