Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Im a first-time user to Ubuntu-12.04 with WUBI installation.

I have a Dell vostro 3450 with i5 2410m, 3 gb ram, intel hd3000, amd 6630m hybrid.

Surfing and playing games works flawlessly. However, I'm having huge problems when installing applications and generally copying and moving files.

When doing so, system is significantly slower and freezes quite often (Firefox gets bluish, sometimes even black n white). I would say that Ubuntu allocates too much resources on file transfers and installing, but even these tasks are very slow.

Here is very specific example : Today I tried to move a 6 GB file from my Windows 7 installation. It was good at first, so I jumped to Firefox but after a while firefox started to randomly turn bluish and mouse was randomly stopping working. It was gradually worse and worse until it got to a point when firefox black and whited and mouse wasn't working at all. I raged and went for some meal, when I got back screen was black. It probably unlogged me due to inactivity, when I pushed random button to bring screen to life I had to wait few minutes to let it show me only my screen background. No log in screen, just background and working mouse. NoteBook fan was working at 100 % so I assumed that file transfer was going on and I left it to work. Nothing then changed for a full hour so I hard rebooted it. File transfer unsuccessful, It transfered hardly 2 gigs. Is this normal ?

What to do in these situations ? It didn't let me load system manager and not even the terminal.

share|improve this question
    
If you run the "free" command in a terminal, does it show any swap being used? –  dobey Jun 22 '12 at 12:52
    
You can check this link for getting a general performance issuce problem with harddisk I/O, see the "mcduck"'s post. You might have already known that, Wubi is a slower method, and not a standard one –  Anwar Shah Jun 25 '12 at 8:03
    
As suggested here, I recommend installing pastebinit (sudo apt-get update && sudo apt-get install pastebinit) and running pastebinit /var/log/dmesg and pastebinit /var/log/kern.log. You'll get a URL for each--add both URL's by editing your question (or comment here with the links if it doesn't let you add both of them). That should make it possible to troubleshoot your problem further. And please go ahead and provide the output of free as well. (To run commands, open the Terminal with Ctrl+Alt+T.) –  Eliah Kagan Jun 25 '12 at 8:12
add comment

3 Answers 3

I noticed the same freezes. While I can't tell why this happens, I know a way to get rid of that. Here's how:

In a terminal, type

echo "deadline" | sudo tee /sys/block/sda/queue/scheduler

Try moving or copying larger ammounts of files again. You should notice a huge difference. If so, make the change permanent by typing in a terminal:

gksudo gedit /etc/default/grub

In the line beginning with GRUB_CMDLINE_LINUX_DEFAULT="", add the following string in between the ""s:

elevator=deadline

Save and exit. After that, type in a terminal

sudo update-grub

Reboot.

FYI: This changes the so-called scheduler to 'deadline'.

Source: http://techtitbits.com/2010/04/get-rid-of-freeze-ups-during-disk-io-activity-in-ubuntu/

================================================================================

Another Possibility would be to lower dirty_ratio settings. To test it, type in a terminal:

sudo bash -c "echo 10 > /proc/sys/vm/dirty_ratio"

sudo bash -c "echo 5 > /proc/sys/vm/dirty_background_ratio"

If this helps, make it permanent by editing your sysctl.conf:

gksudo gedit /etc/sysctl.conf

At the end of the file, add the following lines:

vm.dirty_ratio=10

vm.dirty_background_ratio=5

Save, close and reboot. Done.

share|improve this answer
3  
As that article says, it's helpful to test this first, to see if it will really do any good: echo "deadline" | sudo tee /sys/block/sda/queue/scheduler –  Eliah Kagan Jun 25 '12 at 8:01
    
Thanks, I changed my post accordingly, adding the information you provided, @EliahKagan –  FuzzyQ Jul 28 '12 at 21:31
add comment

You have to remember that Wubi installs Ubuntu in your existing Windows Partition and not in a separate one.

It looks like Ubuntu has no space to work in your existing Windows Partition. It could be trying to use swap but not getting enough which causes the slowing down of the system and the heavy disk activity.

I would either install Ubuntu at a separate partition without Wubi, or expanding your Windows Partition size and the size of your Wubi install.

You can also take a look at this article on how to improve the performance of your hard drive.

share|improve this answer
add comment

From my experience, Disk I/O is the bane of any sane user experience under Linux.

Things that make it worse:

  • Using a laptop(2.5") disk, especially a 5k rpm disk
  • Using wubi or LVM/Encryption.
    • This is because normally, reads/writes to disk are quite optimized to your hardware, but having that enabled creates a layer of indirection that mess this up.

Reasons for the slowdown:

  • Most things on your linux-system need to touch disk quite often, they write logs, cache-files and sometimes they synchronize things through the file-system.
  • When the disk is busy, everything grinds to a halt, waiting for their check on the cache-file etc will complete. This is especially noticeable with gui-applications.

So, in general. Anything you can do to avoid touching disk is good.

You can change your firefox cache-directory to

/run/shm
This is a ram-disk. It is very fast, but anything you store there will

  1. eat your ram
  2. be gone after a reboot.

Tutorials for this can be done by using google.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.