Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i've been fixing the Overheating, thanks for that, it worked, i just reopened my laptop and cleaned it VERY well. but now idle is @ 50*C and not 20-30*C, because of the frequency being at max 2.5GHz. but normaly, at idle, the freq should be very low, like @ 1.2 but when i change it on the freq scaling on Unity, it get back to 2.5.. Any help?

Ubuntu 11.10, i5 M460 @ 2.5GHz

share|improve this question

1 Answer 1

What do you mean with "but when i change it on the freq scaling on Unity, it get back to 2.5"?

Have you triedecho "ondemand" | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor? This would normally save your last used power mode too. Other available power-mode-options are available with cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors.

share|improve this answer
    
yes, i did tryed them, well, with that, i mean, when i'm on userspace governor, i can't control the CPU freq, like, when i select 1.6GHz, it goes back to 2.5GHz is seconds... and even ondemand, it use 2.5GHz. –  Moncef ben slimane Jun 21 '12 at 11:00
    
do you experience this behaviour on another system as well? You might want to check that to determine if it is a software or a hardware problem. –  onse Jun 21 '12 at 12:20
    
Well, on windows i never had this. –  Moncef ben slimane Jun 21 '12 at 12:45
1  
is the PC really idling? Use top to check that there isn't a process taking useless CPU power (because it is stuck in a loop or similar) –  onse Jun 21 '12 at 13:09
    
i've checked everything, but today, i had an update, updated my pc, rebooted and i got control of my frequency back, agin thanks guys –  Moncef ben slimane Jun 22 '12 at 10:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.