Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A few days ago I installed Ubuntu 12.04 32bit Desktop. It recognized my hardware without a problem (at least that I know of) and all worked fine. I left my system running (it is at work) through the night because it is also working as a database server and when I came today to work the resolution was 1024x768 (the monitor recommends 1920x1080) even though in the Display section of the System Settings it was recognized as BenQ, and no higher resolution was offered. After a restart, the monitor name changed from BenQ to Unknown. This is a desktop computer. I also installed gtk-redshift and f.lux.

I checked Additional Drivers to see if there is something I can install but it didn't find anything. I tried to Google it but I didn't find anything about a monitor stopping being recognized after it was already working. I did enable some PPAs yesterday, namely webupd8, mozillateam/thunderbird-stable and some other, and I also followed the instructions to patch the NotifyOSD to be more friendly:

sudo add-apt-repository ppa:caffeine-developers/ppa
sudo add-apt-repository ppa:leolik/leolik 
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libnotify-bin
pkill notify-osd
sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install notifyosdconfig

I now purged both caffeine-developers and leolik PPAs in the hope it will help, but no change. Has there been a change in the packages that could introduce this problem? Any help will be very appreciated :-)

Omri

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

You can try to get the edid data from your monitor. This can be done with the get-edid command

$ sudo apt-get install read-edid
$ get-edid | parse-edid

Did you change your video cable? Some old vga cables do not have the data wire (a wire not used to transmit video signals, but only to interchange data between the computer and the monitor). Maybe that wire got broken if somebody pulled strong from the cable.

You can try to change your video cable, too.

share|improve this answer
    
Thanks for the quick answer :) Just before reading the answer I realized that the embarrassing solution is that the cable wasn't connected all the way, and as a result Ubuntu stopped getting the data for the screen. I guess this is a good lesson to check before posting. I didn't know it can have this effect... –  Omri Jun 21 '12 at 9:17
add comment

Omri, after upgrading to 12.10 my BenQ monitor was not detected any more. I could solve this issue through removing my previously installed proprietary graphics driver ...

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

... and using the default open-source driver.

sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

(source: http://wiki.cchtml.com/index.php/Ubuntu_Lucid_Installation_Guide#Removing_the_Driver)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.