Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I start LibreOffice, I have to wait 3 minutes before I'm able to start working (screen is grey). Why? Are there any ways to fix this problem?

Regrets Malte

share|improve this question
    
What are your computer specifications? –  Uri Herrera Jun 21 '12 at 6:41
    
What specific programm are you using? Impress, Writer or Calc? –  miceterminator Jun 21 '12 at 6:41
    
2,1 Ghz DualCore E4600, 2GB Ram, GeForce 4900GTX, i dont think its cause of my hardware –  Malte D Jun 21 '12 at 6:44
    
Im using Writer –  Malte D Jun 21 '12 at 6:44
    
Does this happen on ubuntu 12.04? Did you upgrade from a previous release? –  medigeek Jun 21 '12 at 6:45

1 Answer 1

How you can see here LibreOffice won't work well with ALL Java versions. The 1.6.0_21 seems to be the best java to use with LibreOffice. The 1.6.0_20 & 1.6.0_22 seem to be in a fairly good 2nd place place. The 1.6.0_24 was really bad and the 1.6.0_26 was even worse apparently.

To install 1.6.0_21 You should first purge every other Java versions from your system (icedtea, open, ecc. all included). Unfortunately, it seems near impossible to find compiled packages for precise, so you'll have to consider to build it from source (https://launchpad.net/ubuntu/+source/sun-java6/6.21-1ubuntu1).

Otherwise, you could disable java plugin for LO, from Tools menu, then Options, Java, uncheck the box.

Last alternative, install other versions of java (such as the last Oracle 1.7) and select it in the list, to see if the problem solves.

share|improve this answer
    
Thanks a lot +1. I disabled Java and it works perfectly now. –  Malte D Jun 21 '12 at 7:58
    
definitely a speed improvement when disabling Java completely in LO –  Dragon5689 Aug 22 '13 at 8:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.