Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Every time I start LibreOffice, I have to wait 3 minutes before I'm able to start working (screen is grey). Why? Are there any ways to fix this problem?

Regrets Malte

share|improve this question
What are your computer specifications? – Uri Herrera Jun 21 '12 at 6:41
What specific programm are you using? Impress, Writer or Calc? – miceterminator Jun 21 '12 at 6:41
2,1 Ghz DualCore E4600, 2GB Ram, GeForce 4900GTX, i dont think its cause of my hardware – Malte D Jun 21 '12 at 6:44
Im using Writer – Malte D Jun 21 '12 at 6:44
Does this happen on ubuntu 12.04? Did you upgrade from a previous release? – medigeek Jun 21 '12 at 6:45

How you can see here LibreOffice won't work well with ALL Java versions. The 1.6.0_21 seems to be the best java to use with LibreOffice. The 1.6.0_20 & 1.6.0_22 seem to be in a fairly good 2nd place place. The 1.6.0_24 was really bad and the 1.6.0_26 was even worse apparently.

To install 1.6.0_21 You should first purge every other Java versions from your system (icedtea, open, ecc. all included). Unfortunately, it seems near impossible to find compiled packages for precise, so you'll have to consider to build it from source (

Otherwise, you could disable java plugin for LO, from Tools menu, then Options, Java, uncheck the box.

Last alternative, install other versions of java (such as the last Oracle 1.7) and select it in the list, to see if the problem solves.

share|improve this answer
Thanks a lot +1. I disabled Java and it works perfectly now. – Malte D Jun 21 '12 at 7:58
definitely a speed improvement when disabling Java completely in LO – Dragon5689 Aug 22 '13 at 8:32

This past week, LO slowed considerably for me, no matter what document. Don't know if it was a change in Java, but LO became unusable in terms of entering numbers in Calc or even typing in Writer.

This is under 14.04 64-bit w/ 8GB of RAM. LO Version:, Build ID: 420m0(Build:2)

As mentioned above, turning off use of the Java runtime environment: Tools>Options>Advanced within LO, and restarting LO seems to have solved the problem, both for Calc and for Writer.

share|improve this answer
no one seems to be answering this question... but it seems to be getting more prevalent. I am seeing a bunch of people asking the same thing. I am having the same thing. But there's no answer. I'm not inexperienced and my laptop is not under load. LibreOffice is doing something weird. – nic ferrier Apr 29 '15 at 18:38
This solution worked for me! – RobinLovelace Jun 4 '15 at 18:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.