Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Trying user1261084 solution:

$ sudo apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.4 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Trying @eric-carvalho solution once more

$ apt-cache policy libgnutls26
libgnutls26:
  Installed: 2.12.19-1
  Candidate: 2.12.19-1
  Version table:
 *** 2.12.19-1 0
        100 /var/lib/dpkg/status
     2.12.14-5ubuntu3.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
     2.12.14-5ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

I was removed ppa:ubuntu-wine/ppa repository (Software Center > Edit > Software Sources > Other Software and manually remove) then went to Ubuntu Software tab and changed Download from to Main Server as user1261084 suggested.

after that I tried to downgrade libgnutls26 to version 2.12.14-5ubuntu3.1:

$ sudo apt-get install libgnutls26=2.12.14-5ubuntu3.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  gnutls-bin
The following packages will be DOWNGRADED:
  libgnutls26
0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 8 not upgraded.
Need to get 459 kB of archives.
After this operation, 326 kB disk space will be freed.
Do you want to continue [Y/n]? Y
Get:1 http://archive.ubuntu.com/ubuntu/ precise-updates/main libgnutls26 amd64 2.12.14-5ubuntu3.1 [459 kB]
Fetched 459 kB in 5s (86.8 kB/s)      
dpkg: warning: downgrading libgnutls26 from 2.12.19-1 to 2.12.14-5ubuntu3.1.
(Reading database ... 267654 files and directories currently installed.)
Preparing to replace libgnutls26 2.12.19-1 (using .../libgnutls26_2.12.14-5ubuntu3.1_amd64.deb) ...
Unpacking replacement libgnutls26 ...
Setting up libgnutls26 (2.12.14-5ubuntu3.1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

it worked so:

$ sudo apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  autopoint rpm librpmbuild2 librpmsign0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  fonts-droid fonts-horai-umefont libasn1-8-heimdal:i386 libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libcapi20-3
  libcapi20-3:i386 libcups2:i386 libexif12:i386 libgcrypt11:i386 libgd2-xpm:i386 libgif4:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386
  libglapi-mesa:i386 libglu1-mesa:i386 libgnutls26:i386 libgpg-error0:i386 libgphoto2-2:i386 libgphoto2-port0:i386 libgssapi-krb5-2:i386
  libgssapi3-heimdal:i386 libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libieee1284-3:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386 libkrb5-3:i386
  libkrb5support0:i386 libldap-2.4-2:i386 libllvm3.0:i386 libltdl7:i386 libmpg123-0:i386 libopenal1:i386 liborc-0.4-0:i386 libp11-kit0:i386
  libroken18-heimdal:i386 libsane:i386 libsasl2-2:i386 libsasl2-modules:i386 libssl1.0.0:i386 libtasn1-3:i386 libusb-0.1-4:i386 libv4l-0:i386
  libv4lconvert0:i386 libwind0-heimdal:i386 libx11-xcb1:i386 libxcb-glx0:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxfixes3:i386
  libxinerama1:i386 libxml2:i386 libxpm4:i386 libxrandr2:i386 libxslt1.1:i386 libxxf86vm1:i386 ttf-droid ttf-umefont wine-gecko1.4 wine-gecko1.4:i386
  wine1.4 wine1.4-amd64 wine1.4-common wine1.4-i386:i386 winetricks
Suggested packages:
  cups-common:i386 rng-tools:i386 libgd-tools:i386 libglide3:i386 gnutls-bin:i386 gphoto2:i386 gtkam:i386 krb5-doc:i386 krb5-user:i386
  libvisual-0.4-plugins:i386 gstreamer-codec-install:i386 gnome-codec-install:i386 gstreamer0.10-tools:i386 gstreamer0.10-plugins-base:i386 hpoj:i386
  hplip:i386 libsane-extras:i386 sane-utils:i386 libsasl2-modules-otp:i386 libsasl2-modules-ldap:i386 libsasl2-modules-sql:i386
  libsasl2-modules-gssapi-mit:i386 libsasl2-modules-gssapi-heimdal:i386 dosbox
Recommended packages:
  xml-core:i386 gettext:i386
The following packages will be REMOVED:
  alien debhelper gettext gnome-common intltool intltool-debian po-debconf
The following NEW packages will be installed:
  fonts-droid fonts-horai-umefont libasn1-8-heimdal:i386 libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libcapi20-3
  libcapi20-3:i386 libcups2:i386 libexif12:i386 libgcrypt11:i386 libgd2-xpm:i386 libgif4:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386
  libglapi-mesa:i386 libglu1-mesa:i386 libgnutls26:i386 libgpg-error0:i386 libgphoto2-2:i386 libgphoto2-port0:i386 libgssapi-krb5-2:i386
  libgssapi3-heimdal:i386 libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libieee1284-3:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386 libkrb5-3:i386
  libkrb5support0:i386 libldap-2.4-2:i386 libllvm3.0:i386 libltdl7:i386 libmpg123-0:i386 libopenal1:i386 liborc-0.4-0:i386 libp11-kit0:i386
  libroken18-heimdal:i386 libsane:i386 libsasl2-2:i386 libsasl2-modules:i386 libssl1.0.0:i386 libtasn1-3:i386 libusb-0.1-4:i386 libv4l-0:i386
  libv4lconvert0:i386 libwind0-heimdal:i386 libx11-xcb1:i386 libxcb-glx0:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxfixes3:i386
  libxinerama1:i386 libxml2:i386 libxpm4:i386 libxrandr2:i386 libxslt1.1:i386 libxxf86vm1:i386 ttf-droid ttf-umefont wine wine-gecko1.4
  wine-gecko1.4:i386 wine1.4 wine1.4-amd64 wine1.4-common wine1.4-i386:i386 winetricks
0 upgraded, 74 newly installed, 7 to remove and 8 not upgraded.
Need to get 143 MB of archives.
After this operation, 408 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
...
Setting up wine1.4-common (1.4-0ubuntu4.1) ...
Setting up wine1.4-amd64 (1.4-0ubuntu4.1) ...
Setting up wine1.4-i386:i386 (1.4-0ubuntu4.1) ...
Setting up wine1.4 (1.4-0ubuntu4.1) ...
Setting up wine (1.4-0ubuntu4.1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

Checking Wine version (Installed: 1.4-0ubuntu4.1)

$ apt-cache policy wine
wine:
  Installed: 1.4-0ubuntu4.1
  Candidate: 1.4-0ubuntu4.1
  Version table:
 *** 1.4-0ubuntu4.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     1.4-0ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages

full log here

Now I have wine 1.4 installed I added ppa:ubuntu-wine/ppa repository again and:

$ sudo apt-get install wine1.5
(...)
$ apt-cache policy wine
wine:
  Installed: 1.5.13-0ubuntu1
  Candidate: 1.5.13-0ubuntu1
  Version table:
 *** 1.5.13-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     1.4-0ubuntu4.1 0
        500 http://mirror.globo.com/ubuntu/archive/ precise-updates/universe amd64 Packages
     1.4-0ubuntu4 0
        500 http://mirror.globo.com/ubuntu/archive/ precise/universe amd64 Packages

So finally I have wine 1.5 installed (^-^) thanks for Eric Carvalho and user1261084 help.

share|improve this question
    
Similar question wine-on-ubuntu-12-04-64bit-wine1-4 –  Moreno Jun 21 '12 at 1:54
    
    
Use Synaptic Package Manager or USC. Dont use command line. –  Curious Apprentice Jun 21 '12 at 2:28
1  
Can you please split this up and post your solution as an answer to the question so that the next person can figure out exactly how to solve this problem? –  Jorge Castro Sep 17 '12 at 13:08
    
show 2 more comments

3 Answers 3

up vote 7 down vote accepted

It seems that multiarch is not enabled. This can happen if you upgrade Ubuntu from a previous version instead of performing a clean installation.

Run the following in a terminal:

echo "foreign-architecture i386" | sudo tee /etc/dpkg/dpkg.cfg.d/multiarch
sudo chmod 644 /etc/dpkg/dpkg.cfg.d/multiarch

Then try to install wine again:

sudo apt-get update
sudo apt-get install wine1.5

If you still get dependency problems, maybe it's because of this bug. wine1.5-amd64 recommends gettext, wine1.5-i386:i386 recommends gettext:i386 and both gettext conflict with each other. I managed to install wine1.5 via aptitude, install it if it's not already installed (sudo apt-get install aptitude):

sudo aptitude install wine1.5 gettext:i386-

The trailing minus (-) will tell aptitude to remove (or skip installation of) gettext:i386.

EDIT:

You have libgnutls26 version 2.12.19, probably installed from a ppa because the latest version available from ubuntu repos is 2.12.14. wine depends on libgnutls26:i386, which must be the same version as libgnutls26, but 2.12.19 is not available for installation. You can try to manually download and install libgnutls26:i386 version 2.12.19, or remove the ppa that installed libgnutls26 version 2.12.19.

Please run apt-cache policy libgnutls26 and post the output. Maybe I can help you to find out a solution.

share|improve this answer
    
You're right I upgraded it from 11.10 but when I tried your solution I got almost same errors –  Moreno Aug 27 '12 at 2:35
    
Sorry, I forgot the dependency resolution bug regarding gettext. Answer updated. –  Eric Carvalho Aug 28 '12 at 0:31
    
I tried you edited solution but it shows a list of packges will be removed (I need skype) so I aborted it –  Moreno Sep 3 '12 at 0:23
    
This is more complicated than I thought. I'll run some tests in a VM and post a reply later. –  Eric Carvalho Sep 3 '12 at 13:03
    
Answer updated. Please run apt-cache policy libgnutls26 and post the output. –  Eric Carvalho Sep 3 '12 at 14:54
show 4 more comments

I had the same problem, but I had no issues anymore after carrying out the following commands:

sudo dpkg --configure -a
sudo apt-get install -f

Then I successfully tried

sudo apt-get install wine1.5
share|improve this answer
    
I tried again - Almost same errors –  Moreno Aug 21 '12 at 21:30
add comment

Go to Ubuntu Software Center > Edit > Software Sources > Other Software

and manually remove ppa:ubuntu-wine/ppa Then go to Ubuntu Software tab, and change:

"Download from" to "Main Server"

Then..

sudo apt-get update && sudo apt-get install wine

Worked for me, good luck!

share|improve this answer
    
It didn't work for me. –  Moreno Sep 16 '12 at 15:53
1  
Changing sources wont help if the bugs were not fixed. the problem was with specifying dependencies as = instead of >= –  Mahesh Oct 22 '12 at 9:47
add comment

protected by Community Oct 22 '12 at 10:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.