Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have a dell studio 1749. I just installed 12.04 on a dual boot with windows 7 (The stereo sound and headphones work perfectly when booted into windows, sound turned up before booting into Ubuntu). The stereo sound seems to be working fine. The headphones, not so much.

My computer has two headphone jacks. When I put my working headphones into the first jack, the stereo sound is muted but there is no sound in the headphones. When I put my headphones into the second jack, the stereo sound is still there and no sound comes out of the headphones. Two different problems?

I first tried the sound troubleshooting found in the comunity support wiki. There seemed to be no problems. However, I'm not positive that my sound cards were on the list. It was a little convoluted for my noob self. I've tried the commands listed here: but there were no changes. I've also brought up the alsamixer. The headphones don't appear to be muted or anything. I don't know how to switch to the second sound card and check that one, though.

Any help would be greatly appreciated!

share|improve this question

2 Answers 2

up vote 4 down vote accepted

I posted the same question on Launchpad. Here was the answer I received from Mark Rijckenberg:

Please run the following command in a Terminal session:

gksudo gedit /etc/modprobe.d/alsa-base.conf

Using the gedit editor, add this line in the /etc/modprobe.d/alsa-base.conf file:

options snd-hda-intel model=dell-m6-dmic

Save the change, close gedit and reboot to test.

The first headphone jack now works. The second one has the same problem as before. I'm happy and hope that this might help someone else.

share|improve this answer
    
13.10 Update: This fix now gives me two working headphone jacks instead of just one!! Huzzah for full fix! –  Danni Oct 23 '13 at 22:56

It seems to be output sound card problem. Sound card automaticly change to hdmi output when 2 application conflicted with it. I fix that with run. It restore output to analog, again.

alsactl -F restore
share|improve this answer
    
While this is technically an answer, it would be greatly improved if you included some explanation as to what this actually accomplishes. –  RPi Awesomeness Dec 27 '14 at 6:10
1  
thank you. I had included some explanation in my answer. –  caisara Dec 29 '14 at 11:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.