Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have several nautilus bookmarks pointing to SSH servers, so that I can easily access them. Out of nowhere this doesn't work anymore. When I open a bookmark or enter ssh://user@server in the location bar, Nautilus completely freezes and doesn't recover (edit: same with sftp://). I can kill Nautilus and the desktop will load again. Everything else works as it should. As soon as I try to access a server through ssh, nautilus freezes again.

Nothing was changed on the servers and no updates have been installed on the computer. A reboot doesn't help, either.

I use key-authentication if that is important. I AM being asked for the key-passphrase and then the freeze occurs.

Update: This stopped working while I was using it. I was uploading some files, did something else, and when I got back to upload some more edited files the freezing began. To me this feels like some messed up or incomplete cache files that nautilus still tries to use.

share|improve this question

closed as too localized by Bruno Pereira Mar 16 '12 at 13:18

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
You should file a bug report, check the following instructions: help.ubuntu.com/community/ReportingBugs –  João Pinto Nov 29 '10 at 19:31
1  
have you checked from the CLI to make sure your keys aren't expired/there isn't some uncaught command line prompt? always a fan of pinning down a problem before i say "something is wrong". that way I can say "I think THIS is wrong" –  hbdgaf Nov 29 '10 at 21:06
    
CLI works. On other computers with the same configuration Nautilus server-connections still work. See updates to the question. –  mniess Dec 1 '10 at 14:12
    
If you open nautilus from a shell and try to click on a ssh bookmark, are there any errors reported on the cli? –  Pavlos G. Dec 2 '10 at 16:24
    
Unfortunately nautilus automatically detaches itself when run from the CLI, so you won't get any messages. There are no verbosity-options, either. –  mniess Dec 3 '10 at 15:57

2 Answers 2

Have you tried mounting the remote filesystem via sshfs and then browsing it via Nautilus? I think that if that works it would then eliminate the remote server, the local ssh client, and non-gvfs parts of Nautilus as problems. (I'm not sure what is in the middle there or if gvfs is involved at all- but it would provide more information if this works.)

share|improve this answer
    
Using sshfs works. Opening the mounts with nautilus works as expected. If it wouldn't work it'd mean nautilus can't open fuse mounts anymore. I tried deleting .gvfs but that didn't help. I'll now try to force-remove/purge all nautilus and gvfs-related packages and reinstall them. –  mniess Dec 3 '10 at 15:53

It may not be a perfect solution but sometimes it may work.

Just try sftp://user@server instead of ssh://user@server

share|improve this answer
    
I'm not sure, but I think they are synonymous. Anyway, the result is the same ;( –  mniess Nov 30 '10 at 12:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.